杭电2577

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6125    Accepted Submission(s): 2748


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
  
  
3 Pirates HDUacm HDUACM
 

Sample Output
 
 
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

最初是想用暴力的,但考虑到Shift,用暴力太过繁琐,后看了大神的思路后,转DP。

用DP应用两个数组,分别表示Caps Lock键开和关的状态所需按键数,然后一点一点依次找到最小所需按键数。

正好昨晚学习了STL的相关内容,以后代码就可以用C/C++和STL混搭的模式了。


AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    char s1[120];
    int t,i,j,len,a[120],b[120];
    cin>>t;
    while(t--)
    {
        cin>>s1;
        len=strlen(s1);
        if(s1[0]>='a'&&s1[0]<='z')
        {
            a[0]=1;
            b[0]=2;
        }
        else
        {
            a[0]=2;
            b[0]=2;
        }
        for(i=1;i<len;i++)
        {
            if((s1[i]>='a'&&s1[i]<='z'))
            {
                a[i]=min(a[i-1]+1,b[i-1]+2);
                b[i]=min(a[i-1]+2,b[i-1]+2);
            }
            else
            {
                a[i]=min(a[i-1]+2,b[i-1]+2);
                b[i]=min(a[i-1]+2,b[i-1]+1);
            }
        }
        b[len-1]++;
        cout<<min(a[len-1],b[len-1])<<endl;
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值