杭电1160 排序+LIS+记录

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14556    Accepted Submission(s): 6429
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.
 

Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
  
  
4 4 5 9 7
 
题意:输入多只老鼠数据(包括质量和速度),以EOF结束。然后输出质量严格递增且速度严格递减的最大老鼠数量,并输出各老鼠的序号。(有可能有序号排列㓟多种情况,输出满足条件的一种即可)
思路:一开始明白题意后,思路很好想,就是按照质量排下序,然后按照速度求最长不递增子序列长度,并记录序号即可。但无奈有了思路后,代码却写得不好,这主要反映了自己将算法转化成代码能力还较弱,有待提高。
写代码时主要遇到的问题是记录序列的序号。首先,在结构体中定义一个num来存储原序号,以至于排列时不乱。然后用dp[i]存储到第i个数的最长序列,用p[i]存储排序后,序列长度每增加一个的位置记录,但是没法记录序列的第一个数,因此又用ans来存储第一个数的位置。

AC代码:
#include <iostream>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 1100
using namespace std;
struct node
{
    int w,s,n;
}m[N];
int dp[N],p[N];
bool cmp(node a,node b)
{
    return a.w<b.w;
}
int main()
{
    //freopen("D://in.txt","r",stdin);
    int k,ans;
    for(k=1;~scanf("%d%d",&m[k].w,&m[k].s);k++)
    {
        m[k].n=k;
        dp[k]=1;
    }
    ans=k;
    dp[ans]=0;
    sort(m,m+k,cmp);
   /* for(int i=1;i<k;i++)
        printf("%d ",m[i].w);
    cout<<endl;*/
    memset(p,0,sizeof(p));
    for(int i=k-1;i>=0;i--)
    {
        for(int j=k-1;j>i;j--)
        {
            if(m[i].w<m[j].w&&m[i].s>m[j].s&&dp[j]+1>dp[i])
            {
                dp[i]=dp[j]+1;
                p[i]=j;
                if(dp[ans]<dp[i])
                    ans=i;
            }
        }
    }
  /*  for(int i=0;i<k;i++)
        printf("%d %d\t",p[i],m[p[i]].n);*/
    cout<<dp[ans]<<endl;
    while(ans!=0)
    {
        cout<<m[ans].n<<endl;
        ans=p[ans];
    }
    return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值