Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 49872 Accepted Submission(s): 20900
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
Sample Output
14
简单的01背包模板题。只是将二维转移方程转换为一维,不然空间不够,但要注意的是由于是01背包,转换为一维后,需j=V…w[i]逆序循环。因为如果顺序的话,则变成dp[i][j]由dp[i][j-w[i]]决定,与题意不符。转移方程为
dp[j]=max(dp[j],dp[j-w[i]]+p[i]);
AC代码:
#include <stdio.h>
#include <string.h>
int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int i,j,n,T,N,V,p[1005],w[1005],dp[1005];
scanf("%d",&T);
while(T--)
{
scanf("%d %d",&N,&V);
for(i=1;i<=N;i++)
scanf("%d",&p[i]);
for(i=1;i<=N;i++)
scanf("%d",&w[i]);
memset(dp,0,sizeof(dp));
for(i=1;i<=N;i++)
for(j=V;j>=w[i];j--)
dp[j]=max(dp[j],dp[j-w[i]]+p[i]);
printf("%d\n",dp[V]);
}
return 0;
}