POJ 3311 Hie with the Pie 【状压dp】

Hie with the Pie
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8464 Accepted: 4625

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8
#include<iostream>
#include<cstring>
using namespace std;
#define mms(x) memset(x, 0, sizeof x)
#define INF 0x3f3f3f3f
const int MAX = 1 << 11;
int a[11][11], dp[MAX][11]; ///dp[i][j]表示从j到状态i的最短路,i通过二进制的方法表示该点是否通过0:未通过,1:通过;
bool judge(int x, int y)
{
    return x & y;
}
int main()
{
    ios::sync_with_stdio(false);
    int n;
    while(cin >> n && n)
    {
        int ak = (1 << n) - 1;///因为起点是0,所以所有点通过的状态即为n个1,1个0;
        for(int i = 0; i <= n; i++)
            for(int j = 0; j <= n; j++)
                cin >> a[i][j];
        for(int k = 0; k <= n; k++)///因为有重复路径,而且可以重复访问,所以用floyed求最短路径;
            for(int i = 0; i <= n; i++)
                for(int j = 0; j <= n; j++)
                    a[i][j] = min(a[i][j], a[i][k] + a[k][j]);
        for(int i = 0; i < ak + 1; i++)///枚举所有状态;
            for(int j = 1; j <= n; j++)
                if(judge(i, 1 << (j - 1)))///状态i经过j点;
                {
                    if(i == 1 << (j - 1))///状态i只经过j点
                        dp[i][j] = a[0][j];///最优解即为初始0到j的距离;
                    else///状态i不仅经过j点;
                    {
                        dp[i][j] = INF;///先将此状态初始化为极大值;
                        for(int k = 1; k <= n; k++)///继续枚举
                            if(judge(i, 1 << (k - 1)) && j != k)///寻找状态i中不是j的点;
                                dp[i][j] = min(dp[i][j], dp[i ^ 1 << (j - 1)][k] + a[k][j]);
                                ///在状态i中没经过j点的情况下,寻找中间点k使0->k + k->i的距离和最小;
                    }
                }
        int ans = INF;
        for(int i = 1; i <= n; i++)
            ans = min(ans, dp[ak][i] + a[i][0]);///寻找合适的中间点;
        cout << ans << endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值