POJ, 1330 Nearest Common Ancestors(找出两个节点最近的公共节点——BFS)

 Nearest Common Ancestors

From:POJ, 1330

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:


In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is.

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y.

Write a program that finds the nearest common ancestor of two distinct nodes in a tree.

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3

题意:
	找出两个节点最近的公共节点。
解题思路:
	先从一个节点出发,从下往上找根节点(即父亲),找到的标记好,直到找到最上的根节点停止。然后让另一个节点从下往上找,当碰到已经标记的节点时,停止查找。输出此时寻找的节点编号。(利用两次DFS).
代码:
#include<iostream>
#include<cstdio>
using namespace std;


const int maxN =11000;
int visited[maxN];
int father[maxN],n;


void input(){
    int a,b;
    scanf("%d",&n);//数据量大的时候建议用scanf.
    for(int i=1;i<=n;i++){
        father[i]=-1;
    }
    for(int i=0;i<n-1;i++){
        scanf("%d%d",&a,&b);
        father[b]=a;
    }
    for(int i=0;i<n;i++){
        visited[i]=0;
    }
}


void bfs1(int x){
    int f=father[x];
    visited[x]=1;
    while(f!=-1){
        visited[f]=1;
        f=father[f];
    }
}


void bfs2(int y){


    while(visited[y]!=1){
        y=father[y];
    }
    printf("%d\n",y);
}


int main(){
    int m,x,y;
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        input();
        scanf("%d%d",&x,&y);
        bfs1(x);
        bfs2(y);
    }
    return 0;
}


                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值