UVA 488 Triangle Wave(输出三角波)


 
Triangle Wave
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF

 Triangle Wave 

In this problem you are to generate a triangular wave form according to a specified pair of Amplitude and Frequency.

Input and Output

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.

Each input set will contain two integers, each on a separate line. The first integer is the Amplitude; the second integer is the Frequency.

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For the output of your program, you will be printing wave forms each separated by a blank line. The total number of wave forms equals the Frequency, and the horizontal ``height'' of each wave equals the Amplitude. The Amplitude will never be greater than nine.

The waveform itself should be filled with integers on each line which indicate the ``height'' of that line.

NOTE: There is a blank line after each separate waveform, excluding the last one.

Sample Input

    
    
1
32

Sample Output

    
    
1
22
333
22
1
1
33
22 3
22


题目大意:
如图所示。
解题思路:
注意最后一行不能有空格,两组输入数据之间也要有空格。

#include<iostream>
#include<cstdio>
using namespace std;

int n,a,b;

void solve(){
    for(int j=0;j<b;j++){
        for(int i=1;i<=a;i++){
            for(int k=1;k<=i;k++){
                printf("%d",i);
            }
            printf("\n");


        }
        for(int i=a-1;i>=1;i--){
            for(int k=i;k>=1;k--){
                printf("%d",i);
            }
            printf("\n");
        }
        if(j!=b-1){
             printf("\n");
        }
    }
}

int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d%d",&a,&b);
        solve();
        if(i!=n-1){
             printf("\n");
        }
    }
    return 0;
}


代码:




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值