hdu 1896 Stone

Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 
 

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 

Output
Just output one line for one test case, as described in the Description.
 

Sample Input
  
  
2 2 1 5 2 4 2 1 5 6 6
 

Sample Output
  
  
11 12

这是一道优先队列的题目;

根据距离和扔的距离反复进行入队出队操作即可;

#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
struct Stone
{
    int pi;
    int di;
};
//定义优先次序
struct cmp
{
    bool operator ()(Stone &a,Stone &b)
    {
        if(a.pi!=b.pi) return a.pi>b.pi;
        else return a.di>b.di;
    }
};
priority_queue<Stone,vector<Stone>,cmp> pq;
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int N;
        cin>>N;
        Stone stone;
        for(int i=0;i<N;++i)
        {
            cin>>stone.pi>>stone.di;
            pq.push(stone);
        }
        Stone ans;
        int num=0;
        //模拟过程
        while(!pq.empty())
        {
            ++num;
            ans=pq.top();
            pq.pop();
            if(num%2==1)
            {
                ans.pi+=ans.di;
                pq.push(ans);
            }
        }
        cout<<ans.pi<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值