HDU 1896:Stones(优先队列)

Stones

Time limit:3000 ms Memory limit:32768 kB OS:Windows


Problem Description

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0

Output

Just output one line for one test case, as described in the Description.

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12


题意:

现在来扔石头,如果是奇数次就扔,偶数次就不扔,现在告诉我们石头的初始坐标和能扔的距离,问最远的石头离初始(0)有多远。(如果在一个位置遇见多个石头,则先扔扔出距离小的)

解题思路:

没有任何难度,直接模拟扔石头的过程,把每个石头加入到优先队列中(位置的优先级最高,其次是能扔的距离),奇数次则把该石头扔出去(出队,pos+=dis再次入队),偶数次则直接出队,直到队空为止。


Code:

#include <iostream>
#include <queue>
using namespace std;

struct stone
{
    int pos;
    int dis;
    friend bool operator <(stone a,stone b)
    {
        if(a.pos==b.pos)
            return a.dis>b.dis;
        return a.pos>b.pos;
    }
};



priority_queue<stone> q;

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            stone a;
            cin>>a.pos>>a.dis;
            q.push(a);
        }
        int cnt=0,ans=0;
        while(!q.empty())
        {
            cnt++;
            stone b=q.top();
            q.pop();
            if(cnt%2)
            {
                b.pos+=b.dis;
                if(ans<b.pos)
                    ans=b.pos;
                q.push(b);
            }
        }
        cout<<ans<<endl;
    }

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值