【HDU]-1896-Stones(优先队列,好)

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 2009    Accepted Submission(s): 1315


Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
 

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 

Output
Just output one line for one test case, as described in the Description.
 

Sample Input
  
  
2 2 1 5 2 4 2 1 5 6 6
 

Sample Output
  
  
11 12
 

每次走一次更新一下距离,然后把它加入队列中再次比较前进。

结束是最后一次遇到是偶数

注意:要把每次新算出来的位置加入队列再次比较

#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
	int p,d;								//p位置,d距离 
	bool friend operator < (node a,node b)
	{
		if(a.p==b.p)						//位置相同,选择距离近的 
			return a.d>b.d;
		else
			return a.p>b.p;						//位置从近到远排序 
	}	
}pr;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		int maxx=0;
		scanf("%d",&n);
		priority_queue<node> qu;
		for(int i=1;i<=n;i++)
		{
			scanf("%d %d",&pr.p,&pr.d);
			qu.push(pr);
		}
		int ti=0;
		while(!qu.empty())
		{
			pr=qu.top();
			qu.pop();
			ti++;
			if(ti&1)				//记录奇偶 
			{
				pr.p+=pr.d;				//当前位置等于前位置加可以仍的距离 
				maxx=max(maxx,pr.p);		//当前位置等于前位置加可以仍的距离 
				qu.push(pr);			//新的距离 加入比较	
			} 
		}
		printf("%d\n",maxx);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值