hdu 1524 A Chess Game 博弈之,SG函数简单题

23 篇文章 0 订阅

A Chess Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1489    Accepted Submission(s): 679


Problem Description
Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again.

Do you want to challenge me? Just write your program to show your qualification!
 

Input
Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.
 

Output
There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.
 

Sample Input
  
  
4 2 1 2 0 1 3 0 1 0 2 0 2 0 4 1 1 1 2 0 0 2 0 1 2 1 1 3 0 1 3 0
 

Sample Output
  
  
WIN WIN WIN LOSE WIN
 

Wrong了很多次,,让我万万没想到的是,,竟然是初始化错了。。。

哎,什么时候才能克服这种低级错误。。

代码:

#include <stdio.h>
#include <string.h>
#define MAX 1010
bool graph[MAX][MAX];
int n , sg[MAX] , in[MAX];
int getSG(int index)
{
	if(sg[index] != -1)
	{
		return sg[index] ;
	}
	bool hash[MAX] ;
	memset(hash,false,sizeof(hash)) ;
	for(int i = 0 ; i < n ; ++i)
	{
		if(graph[index][i])
		{
			hash[getSG(i)] = true ;
		}
	}
	for(int i = 0 ; i < MAX; ++i)
	{
		if(!hash[i])
		{
			sg[index] = i ;
			break ;
		}
	}
	return sg[index] ;
}

int main()
{
	while(~scanf("%d",&n))
	{
		memset(graph,false,sizeof(graph)) ; 
		memset(sg,-1,sizeof(sg)) ;
		memset(in,0,sizeof(in)) ;
		for(int i = 0 ; i < n ; ++i)
		{
			int m;
			scanf("%d",&m);
			for(int j = 0 ; j < m ; ++j)
			{
				int temp; ;
				scanf("%d",&temp) ;
				in[temp]++ ;
				graph[i][temp] = true ;
			}
		}
		for(int i = 0 ; i < n ; ++i)
		{
			if(in[i] == 0)
			{
				getSG(i) ;
			}
		}
		int m ;
		while(scanf("%d",&m) && m)
		{
			int ans = 0 ;
			for(int i = 0 ; i < m ; ++i)
			{
				int t ;
				scanf("%d",&t) ;
				ans ^= sg[t] ;
			}
			if(ans)
			{
				puts("WIN") ;
			}
			else
			{
				puts("LOSE") ;
			}
		}
	}
	return 0 ;
}

与君共勉

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值