hdoj5400Arithmetic Sequence【等差数列】

Arithmetic Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1315    Accepted Submission(s): 569


Problem Description
A sequence  b1,b2,,bn  are called  (d1,d2) -arithmetic sequence if and only if there exist  i(1in)  such that for every  j(1j<i),bj+1=bj+d1 and for every  j(ij<n),bj+1=bj+d2 .

Teacher Mai has a sequence  a1,a2,,an . He wants to know how many intervals  [l,r](1lrn)  there are that  al,al+1,,ar  are  (d1,d2) -arithmetic sequence.
 

Input
There are multiple test cases.

For each test case, the first line contains three numbers  n,d1,d2(1n105,|d1|,|d2|1000) , the next line contains  n  integers  a1,a2,,an(|ai|109) .
 

Output
For each test case, print the answer.
 

Sample Input
  
  
5 2 -2 0 2 0 -2 0 5 2 3 2 3 3 3 3
 

Sample Output
  
  
12 5
 

Author
xudyh
 

Source
 

题意:给定一个序列求在这个序列中左边满足公差为d1的公差序列右边满足公差为d2的区间个数区间只有一个数或只有两个数满足任一个公差均可

枚举每一个数左边满足d1的元素个数a和右边满足公差为d2的元素个数b则以这个数为分界线总长度为a+b+1的序列满足条件的区间个数即为(a+1)*(b+1)

列如 公差为 2 -2 序列为0 2 0 则以2位分界线 a=1;b=1;则区间个数为4 {0,0},{0,2,0},{2,2},{2,0};

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
const int maxn=100010;
long long l[maxn];
long long r[maxn];
long long num[maxn];
int main()
{
	int n,d1,d2,i,j,k;
	while(scanf("%d%d%d",&n,&d1,&d2)!=EOF){
		for(i=1;i<=n;++i){
			l[i]=r[i]=1;
		}
		int left,right;
		long long ans1=0,ans2=0;
		for(i=1;i<=n;++i){
			scanf("%lld",&num[i]);
			if(i!=1&&num[i]-num[i-1]==d1){
				l[i]+=(i-left);
				ans1+=l[i];
			}
			else {
				left=i;
				ans1+=l[i];
			}
		}
		for(i=n;i>=1;--i){
			if(i!=n&&num[i+1]-num[i]==d2){
				r[i]+=(right-i);
				ans2+=l[i]*r[i];
			}
			else {
				right=i;
				ans2+=l[i]*r[i];
			}
		}
		printf("%lld\n",d1==d2?ans1:ans2);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值