状态压缩DP-HDU-1074-Doing Homework

Doing Homework

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6694 Accepted Submission(s): 2889

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject’s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject’s homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

Sample Input
2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output
2
Computer
Math
English
3
Computer
English
Math

Hint

In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the
word “English” appears earlier than the word “Math”, so we choose the first order. That is so-called alphabet order.

Author
Ignatius.L

题意是有n门课程的作业要交,分别有对应的提交规定时间和做作业要消耗的时间,如果超过规定时间提交,每晚一天扣一分。
求的是按照什么样的顺序完成n门课的作业使得扣分最少。
n不会超过15,用状态压缩,1代表该课作业已经完成,0反之。
则枚举1~(1 < < N)-1,即所有状态。
每个状态存有当前消耗时间,扣去分数以及前驱。
每个状态i,遍历1~N,找到j使得i&(1<<(j-1))==1,即第j门课程的作业在当前状态i下,是完成了的,那么就能去找状态i-(1<<(j-1)),这个状态只要完成作业j,就能达到状态i,于是构建状态转移方程。
dp[i]表示状态i下最少扣除的分数。
令k=i-(1<<(j-1)),sub为从k状态做完作业j索要扣去的分数,则有dp[i]=min(dp[i],dp[k]+sub)。
最后输出dp[(1 < < N)-1]即是最少扣分数。
同时利用已经存入的前驱,输出做作业的顺序,由于输入时已是字典序,所以输出时的字典序可以不额外判断。

//
//  main.cpp
//  基础DP1-D-Doing Homework
//
//  Created by 袁子涵 on 15/10/23.
//  Copyright © 2015年 袁子涵. All rights reserved.
//

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>

#define INF 0x7fffffff

using namespace std;

int N;

typedef struct {
    char name[105];
    int d,c;
}course;

typedef struct {
    int cost,substract,pre,pres;
}Dp;

course classes[20];
Dp dp[(1<<15)+10];

void outputname(int num)
{
    if (num==0) {
        return;
    }
    outputname(num-dp[num].pres);
    printf("%s\n",classes[dp[num].pre].name);

}
int main(int argc, const char * argv[]) {
    int T,sub,temp,bit;
    cin  >> T;
    while (T--) {
        cin >> N;
        for (int i=1; i<=N; i++) {
            scanf("%s%d%d",classes[i].name,&classes[i].d,&classes[i].c);
        }
        dp[0].cost=0;
        dp[0].pre=0;
        dp[0].substract=0;
        bit=1<<N;
        for (int i=1; i<=bit-1; i++) {
            dp[i].substract=INF;
            for (int j=N; j>=1; j--) {
                temp=1<<(j-1);
                if (i&temp) {
                    sub=dp[i-temp].cost+classes[j].c-classes[j].d;
                    if (sub<0) {
                        sub=0;
                    }
                    if (dp[i].substract>sub+dp[i-temp].substract) {
                        dp[i].substract=min(sub+dp[i-temp].substract,dp[i].substract);
                        dp[i].cost=dp[i-temp].cost+classes[j].c;
                        dp[i].pres=temp;
                        dp[i].pre=j;
                    }
                }
            }
        }
        cout << dp[bit-1].substract << endl;
        outputname(bit-1);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值