(HDU 5927)Auxiliary Set 思维题 <2016CCPC东北地区大学生程序设计竞赛 - 重现赛 >

Auxiliary Set
Problem Description
Given a rooted tree with n vertices, some of the vertices are important.

An auxiliary set is a set containing vertices satisfying at least one of the two conditions:

∙It is an important vertex
∙It is the least common ancestor of two different important vertices.

You are given a tree with n vertices (1 is the root) and q queries.

Each query is a set of nodes which indicates the unimportant vertices in the tree. Answer the size (i.e. number of vertices) of the auxiliary set for each query.

Input
The first line contains only one integer T (T≤1000), which indicates the number of test cases.

For each test case, the first line contains two integers n (1≤n≤100000), q (0≤q≤100000).

In the following n -1 lines, the i-th line contains two integers ui,vi(1≤ui,vi≤n) indicating there is an edge between uii and vi in the tree.

In the next q lines, the i-th line first comes with an integer mi(1≤mi≤100000) indicating the number of vertices in the query set.Then comes with mi different integers, indicating the nodes in the query set.

It is guaranteed that ∑qi=1mi≤100000.

It is also guaranteed that the number of test cases in which n≥1000 or ∑qi=1mi≥1000 is no more than 10.

Output
For each test case, first output one line “Case #x:”, where x is the case number (starting from 1).

Then q lines follow, i-th line contains an integer indicating the size of the auxiliary set for each query.

Sample Input
1
6 3
6 4
2 5
5 4
1 5
5 3
3 1 2 3
1 5
3 3 1 4

Sample Output
Case #1:
3
6
3

这里写图片描述

题意:
给你一棵树,有n个节点,q次查询,每次查询告诉你m个非重要节点(其余都是重要节点),问你每次查询时Auxiliary Set元素有多少个?
满足一下两点中的一点即可为Auxiliary Set元素:
1:是重要节点
2:是两个重要节点的最近公共祖先

分析:
其实这一题就是问有多少个非重要节点可以是Auxiliary Set元素,即是两个重要节点的最近公共祖先。
首先对树进行一次dfs,求出每个节点的父亲和儿子的个数,以及其深度。
然后对于m个不重要节点,按深度从大到小排序,然后依次判断:对于当前点,
如果它的儿子数量大于等于2,说明他有两个重要节点孩子,那么当前点一定是一个重要节点;
如果儿子数量等于1,那么关系到当前点的祖先节点是不是重要节点,不处理;
如果孩子数等于0,那么当前点肯定不是重要节点,同时其父亲节点的儿子数量减1
只要满足孩子数大于等于2的都是Auxiliary Set元素。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int maxn = 100010;
struct egde
{
    int u,v,next;
}edges[2*maxn];
int head[maxn];
int n,m,q,e;
int par[maxn],son[maxn],tson[maxn],dep[maxn],qs[maxn];
bool vis[maxn];

void addedge(int u,int v)
{
    edges[e].u = u;
    edges[e].v = v;
    edges[e].next = head[u];
    head[u] = e++;
}

void dfs(int u,int fa,int d)
{
    vis[u] = true; par[u] = fa; dep[u] = d;
    for(int i=head[u];i!=-1;i=edges[i].next)
    {
        if(!vis[edges[i].v])
        {
            dfs(edges[i].v,u,d+1);
            son[u]++;
        }
    }
}

int cmp(int a,int b)
{
    return dep[a] > dep[b];
}

int main()
{
    int t,u,v;
    int kase=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&q);
        e = 0;
        memset(head,-1,sizeof(head));
        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&u,&v);
            addedge(u,v);
            addedge(v,u);
        }
        memset(vis,false,sizeof(vis));
        memset(son,0,sizeof(son));
        dfs(1,-1,1);
        printf("Case #%d:\n", kase++);
        while(q--)
        {
            scanf("%d",&m);
            for(int i=1;i<=m;i++) scanf("%d",&qs[i]);
            for(int i=1;i<=m;i++) tson[qs[i]] = son[qs[i]];
            sort(qs+1,qs+m+1,cmp);
            int ans = n - m;
            for(int i=1;i<=m;i++)
            {
                if(tson[qs[i]] >= 2) ans++;
                else if(tson[qs[i]] == 0) tson[par[qs[i]]]--;
            }
            printf("%d\n",ans);
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值