POJ1694,An Old Stone Game,读懂题目+dfs

An Old Stone Game

Description

There is an old stone game, played on an arbitrary general tree T. The goal is to put one stone on the root of T observing the following rules: 
At the beginning of the game, the player picks K stones and puts them all in one bucket. 
At each step of the game, the player can pick one stone from the bucket and put it on any empty leaf. 
When all of the r immediate children of a node p each has one stone, the player may remove all of these r stones, and put one of the stones on p. The other r - 1 stones are put back into the bucket, and can be used in the later steps of the game.
The player wins the game if by following the above rules, he succeeds to put one stone on the root of the tree. 
You are to write a program to determine the least number of stones to be picked at the beginning of the game (K), so that the player can win the game on the given input tree. 


Input

The input describes several trees. The first line of this file is M, the number of trees (1 <= M <= 10). Description of these M trees comes next in the file. Each tree has N < 200 nodes, labeled 1, 2, ... N, and each node can have any possible number of children. Root has label 1. Description of each tree starts with N in a separate line. The following N lines describe the children of all nodes in order of their labels. Each line starts with a number p (1 <= p <= N, the label of one of the nodes), r the number of the immediate children of p, and then the labels of these r children.


Output

One line for each input tree showing the minimum number of stones to be picked in step 1 above, in order to win the game on that input tree.


Sample Input

2
7
1 2 2 3
2 2 5 4
3 2 6 7
4 0
5 0
6 0
7 0
12
1 3 2 3 4
2 0
3 2 5 6
4 3 7 8 9
5 3 10 11 12
6 0
7 0
8 0
9 0
10 0
11 0
12 0


Sample Output

3
4


分析:

题目不难理解,关键是采用的存储结构,以及dfs的遍历方式。

这里用一个二维数组tree来存储。第i行输入tree[i]中。考虑填充每一个节点需要的石子数,存到数组num[i]中,对num[i]排序,num[i]+i的最大值就是所求结果。


code:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int tree[200+5][200+5];
bool cmp(int a,int b)
{
    return a>b;
}
int dfs(int index)
{
      int  num[205],max,i;
      if(!tree[index][0])
          return 1;
      else
      {
          for(i=1;i<=tree[index][0];i++)
              num[i-1]=dfs(tree[index][i]);
          sort(num,num+tree[index][0],cmp );
          for(i=0,max=-1;i<tree[index][0];++i)
          if(max<num[i]+i) max=num[i]+i;
          return max;
      }
}
int main()
{
    int m,n,i,j,p;
    scanf("%d",&m);
    while(m--)
    {
        memset(tree,0,sizeof(tree));
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            scanf("%d %d",&p,&tree[i][0]);
            for(j=1;j<=tree[i][0];j++)
                scanf("%d",&tree[i][j]);
        }
        printf("%d\n",dfs(1));
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值