Tiling (poj-2506)

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251
 
分析:
    这道题  递归+大数运算(用数组做)
假设我们已经铺好了2×(n-1)的情形,则要铺到2×n则只能用2×1的地板
假设我们已经铺好了2×(n-2)的情形,则要铺到2×n则可以选择1个2×2或两个2×1,故可能有下列三种铺法

    

其中要注意到第三个会与铺好2×(n-1)的情况重复,故不可取,故可以得到递推式

a[i]=2*a[i-2]+a[i-1];

#include <cstdio>
#include <cmath>
#include <string>
using namespace std;
char a[260][1000];
void add(char b[],char c[],char d[])
{
    int i,j,k=0,up=0;
    int x,y,z,t;
    i=strlen(b)-1,j=strlen(c)-1;
    while(i>=0||j>=0)
    {
        if(i<0) x=0;else x=b[i]-'0';
        if(j<0) y=0;else y=c[j]-'0';
        z=x+y+up;
        if(z>9)
        {
            up=1;
            z-=10;
        }
        else
            up=0;
        d[k++]=z+'0';
        i--,j--;
    }
    if(up)
        d[k++]='1';
    d[k]='\0';
    for(i=0;i<k/2;i++)
    {
        t=d[i];
        d[i]=d[k-i-1];
        d[k-i-1]=t;
    }
}
void init()
{
    int i;
    char b[1000];
    strcpy(a[0],"1");
    strcpy(a[1],"1");
    for(i=2;i<=250;i++)
    {
        add(a[i-2],a[i-2],b);
        add(a[i-1],b,a[i]);
    }
}

int main()
{
    init();
    int n;
    while(~scanf("%d",&n))
    {
       printf("%s\n",a[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值