HDU-4190-Distributing Ballot Boxes



Distributing Ballot Boxes

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 926    Accepted Submission(s): 468


Problem Description
Today, besides SWERC'11, another important event is taking place in Spain which rivals it in importance: General Elections. Every single resident of the country aged 18 or over is asked to vote in order to choose representatives for the Congress of Deputies and the Senate. You do not need to worry that all judges will suddenly run away from their supervising duties, as voting is not compulsory.
The administration has a number of ballot boxes, those used in past elections. Unfortunately, the person in charge of the distribution of boxes among cities was dismissed a few months ago due to nancial restraints. As a consequence, the assignment of boxes to cities and the lists of people that must vote in each of them is arguably not the best. Your task is to show how efficiently this task could have been done.
The only rule in the assignment of ballot boxes to cities is that every city must be assigned at least one box. Each person must vote in the box to which he/she has been previously assigned. Your goal is to obtain a distribution which minimizes the maximum number of people assigned to vote in one box.
In the first case of the sample input, two boxes go to the fi rst city and the rest to the second, and exactly 100,000 people are assigned to vote in each of the (huge!) boxes in the most efficient distribution. In the second case, 1,2,2 and 1 ballot boxes are assigned to the cities and 1,700 people from the third city will be called to vote in each of the two boxes of their village, making these boxes the most crowded of all in the optimal assignment.
 

Input
The fi rst line of each test case contains the integers N (1<=N<=500,000), the number of cities, and B(N<=B<=2,000,000), the number of ballot boxes. Each of the following N lines contains an integer a i,(1<=a i<=5,000,000), indicating the population of the i th city.
A single blank line will be included after each case. The last line of the input will contain -1 -1 and should not be processed.
 

Output
For each case, your program should output a single integer, the maximum number of people assigned to one box in the most efficient assignment.
 

Sample Input
  
  
2 7 200000 500000 4 6 120 2680 3400 200 -1 -1
 

Sample Output
  
  
100000 1700
 

Source
SWERC 2011





经典想法就是二分从1到max节点判断,是超过箱子数,还是不到从而判断是小端缩进,还是大端缩进。直到大小端点相交。



另外感觉用概率论的权重的方法也可以作,据说有可能爆,具体从来没有尝试过。



PS:

cstdio是将stdio.h的内容用C++头文件的形式表示出来。stdio.h是C标准函数库中的头文件,即:standard buffered input&output。提供基本的文字的输入输出流操作(包括屏幕和文件等)。由于C语言并没有提供专用于文字输入输出的关键字,所以该库是最普遍的C语言程序加载库。

stdio.h是以往的C和C++的头文件,cstdio是标准C++(STL),且cstdio中的函数都是定义在一个名字空间std里面的,如果要调用这个名字空间的函数,必须得加std::或者在文件中声明use namespace std。




Scode:
#include <cstdio>
#include <iostream>

using namespace std;

int city[8000010];

int main()
{
    int N, B, max, i;

    while(scanf("%d%d", &N, &B))
    {
        if(N == -1 && B == -1) break;

        max = 0;

        for(i = 0; i < N; i++)
        {
            scanf("%d", &city[i]);
            if(max < city[i])  max = city[i]; //找到最大人数的城市
        }

        int l = 1, r = max, x, num, min = max;

        while(l < r)      //核心算法 — — 二分
        {
            num  = 0;     //清空对于票箱的记录

            int mid = (l + r) / 2;   //设置二分的节点作为最大投票箱的可能的最小值
                                     //逐次在1至max之间缩小范围
            for(i = 0; i < N; i++)   //枚举所有的城市
            {
                if (city[i] % mid)  num += (city[i] / mid) + 1;  //求整数再加一
                else num += city[i] / mid;    //恰好需要再增加多少投票箱
            }
            if (num > B)  l = mid + 1;   //从大侧缩小范围,改变节点为端点
                                         //至少也要mid + 1的票
            else   r = mid;              //从小侧缩小范围,改变节点为端点
                                         //mid - 1 有可能会使l漏取mid正确值
        }

        printf("%d\n",l);

    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值