H电-Problem Archive-5123-who is the best?

who is the best?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 210    Accepted Submission(s): 143


Problem Description
There are N people want to choose the best person. Each person select the best person  ai, .John wants to know that who received the most number of votes.
 

Input
The first line contains a single integer  T(1T50),indicating the number of test cases.
Each test case begins with an integer  N(1N100),indicating the number of person.
Next N lines contains an integer  ai(1aiN).
 

Output
For each case, output an integer means who is the best person. If there are multiple answers, print the minimum index.
 

Sample Input
 
 
21012345678910533333
 

Sample Output
 
 
13
 

Source

BestCoder Round #20






秒过小题,轻松一下 (=   。 =)






S:

#include<stdio.h>
#include<string.h>

int main(){
    int T, N[105], p, pp, v, ans;

    scanf("%d", &T);
    while(T--){
        memset(N, 0, sizeof(N));
        scanf("%d", &p);
        pp = p;
        while(p--){
            scanf("%d", &v);
            N[v] = N[v] + 1;
        }
    ans = 1;
    for(int i = 0; i < pp; i++){
        if(N[i] > N[ans]) ans = i;
    }
    printf("%d\n", ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值