HDU - 4190 Distributing Ballot Boxes

Today, besides SWERC'11, another important event is taking place in Spain which rivals it in importance: General Elections. Every single resident of the country aged 18 or over is asked to vote in order to choose representatives for the Congress of Deputies and the Senate. You do not need to worry that all judges will suddenly run away from their supervising duties, as voting is not compulsory.
The administration has a number of ballot boxes, those used in past elections. Unfortunately, the person in charge of the distribution of boxes among cities was dismissed a few months ago due to nancial restraints. As a consequence, the assignment of boxes to cities and the lists of people that must vote in each of them is arguably not the best. Your task is to show how efficiently this task could have been done.
The only rule in the assignment of ballot boxes to cities is that every city must be assigned at least one box. Each person must vote in the box to which he/she has been previously assigned. Your goal is to obtain a distribution which minimizes the maximum number of people assigned to vote in one box.
In the first case of the sample input, two boxes go to the fi rst city and the rest to the second, and exactly 100,000 people are assigned to vote in each of the (huge!) boxes in the most efficient distribution. In the second case, 1,2,2 and 1 ballot boxes are assigned to the cities and 1,700 people from the third city will be called to vote in each of the two boxes of their village, making these boxes the most crowded of all in the optimal assignment.

Input

The fi rst line of each test case contains the integers N (1<=N<=500,000), the number of cities, and B(N<=B<=2,000,000), the number of ballot boxes. Each of the following N lines contains an integer a i,(1<=a i<=5,000,000), indicating the population of the i th city.
A single blank line will be included after each case. The last line of the input will contain -1 -1 and should not be processed.

Output

For each case, your program should output a single integer, the maximum number of people assigned to one box in the most efficient assignment.

Sample Input

2 7
200000
500000

4 6
120
2680
3400
200

-1 -1

Sample Output

100000
1700

题解:给出城市的个数和投票箱的个数,接下来给出每个城市的人数,求出一个投票箱给最多使用人数的最小值。

对人数二分,然后分配箱子,每次更新用的箱子以及容量,最后所得即为容量。

贴代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int mp[5000500],n,m;
int main()
{
    while(~scanf("%d%d",&n,&m)&&(n!=-1||m!=-1))
    {
        int i,j,maxx=0;
        for(i=0; i<n; i++)
        {
            scanf("%d",&mp[i]);
            if(mp[i]>maxx)
                maxx=mp[i];//人数最多的
        }
        int l=0,r=maxx,f;
        while(l<=r)
        {
            int mid=(l+r)/2;
            f=0;//所需盒子数
            for(i=0; i<n; i++)
            {
                if(mid>=mp[i])
                    f+=1;
                else
                    f+=(mp[i]+mid-1)/mid;//更新f
            }
            if(f>m)
                l=mid+1;
            else
                r=mid-1;
        }
        printf("%d\n",l);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值