Ignatius and the Princess III(母函数一种技巧性的暴力)

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13070    Accepted Submission(s): 9236


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
 
题意:整数划分,给你一个整数n,问有多少种方式划分整数;比如2可以划分为2,1+1;

意解:母函数模板;  母函数其实就是把组合加法与幂指数的乘法法则联合在一起

         
#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;
const int M = 1e4 * 2;
typedef long long ll;

ll a[M],b[M];
/********/
/*
 * 母函数,a数组是维护当前能组成的数的方法数,b数组为中间量;
 * 母函数其实就是把组合加法于幂指数的乘法法则联合在一起
 * 这相当于暴力查找符合题意的方法种数,取于不取的问题,取几个的问题;
 */
 
int main()
{
   int n;
   while(~scanf("%d",&n))
   {
       for(int i = 0; i <= n; i++)
       {
           a[i] = 1;
           b[i] = 0;
       }
       for(int i = 2; i <= n; i++)
       {
           for(int j = 0; j <= n; j++) //当前序列的指数
           {
               for(int k = 0; k + j <= n; k += i) //接下来序列的指数,因为指数是以i递增的;
               {
                   b[k + j] += a[j];
               }
           }
           for(int j = 0; j <= n; j++) //更新序列;
           {
               a[j] = b[j];
               b[j] = 0;
           }
       }
       printf("%I64d\n",a[n]);
   }
   return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值