POJ3070-Fibonacci

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16092 Accepted: 11309

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source



题意:给出Fibonacci的第n项的矩阵递推方法,问Fn的最后四位是什么。

解题思路:矩阵快速幂取模。



#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <set>
#include <stack>
#include <map>
#include <climits>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n;

struct Matrix
{
	int v[9][9];
	Matrix()
	{
		memset(v, 0, sizeof v);
	}
};

Matrix mul(Matrix a, Matrix b, int d)
{
	Matrix ans;
	for (int i = 1; i<=d; i++)
	{
		for (int j = 1; j<=d; j++)
		{
			for (int k = 1; k<=d; k++)
			{
				ans.v[i][j] += (a.v[i][k] * b.v[k][j])%10000;
				ans.v[i][j] %= 10000;
			}
		}
	}
	return ans;
}

Matrix pow(Matrix a, int k, int d)
{
	Matrix ans = a;
	while (k)
	{
		if (k & 1) ans = mul(ans, a, d);
		k >>= 1;
		a = mul(a, a, d);
	}
	return ans;
}

int main()
{
	while (~scanf("%d", &n)&&n!=-1)
	{
		Matrix a, ans;
		a.v[1][1] = a.v[1][2] = a.v[2][1] = 1;
		a.v[2][2] = 0;
		ans = pow(a, n, 2);
		printf("%d\n", ans.v[2][2]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值