poj3070——Fibonacci(矩阵快速幂)

41 篇文章 0 订阅
29 篇文章 0 订阅

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

这里写图片描述.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1
Sample Output

0
34
626
6875

就是求斐波那契数列的第n位,可以用矩阵快速幂来求这个递推式f(n)=f(n-1)+f(n-2)
转化成
1,1 f(n-1) f(n)
1,0 x f(n-2) = f(n-1)

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#define INF 0x3f3f3f3f
#define MAXN 10000005
#define Mod 10000
using namespace std;
long long n;
struct Matrix
{
    long long mat[2][2];
};
Matrix unit_mat=
{
    1,0,
    0,1
};
Matrix mul(Matrix a,Matrix b)
{
    Matrix res;
    for(int i=0; i<2; ++i)
        for(int j=0; j<2; ++j)
        {
            res.mat[i][j]=0;
            for(int k=0; k<2; ++k)
            {
                res.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
                res.mat[i][j]%=Mod;
            }
        }
    return res;
}
Matrix pow_matrix(Matrix a,long long n)
{
    Matrix res = unit_mat;
    while(n!=0)
    {
        if(n%2)
            res=mul(res,a);
        a=mul(a,a);
        n>>=1;
    }
    return res;
}
int main()
{
    Matrix tmp,arr;
    while(~scanf("%I64d",&n))
    {
        if(n==-1)
            break;
        if(n==0)
            printf("0\n");
        else if(n==1)
            printf("1\n");
        else if(n==2)
            printf("1\n");
        else
        {
            long long f1=1,f2=1;
            memset(arr.mat,0,sizeof(arr.mat));
            memset(tmp.mat,0,sizeof(tmp.mat));
            arr.mat[0][0]=f2;
            arr.mat[1][0]=f1;
            tmp.mat[0][0]=tmp.mat[0][1]=tmp.mat[1][0]=1;
            Matrix p=pow_matrix(tmp,n-2);
            p=mul(p,arr);
            long long ans=p.mat[0][0]%Mod;
            printf("%I64d\n",ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值