hdu 1595 find the longest of the shortest(最短路+枚举)

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2696    Accepted Submission(s): 972


Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
 

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
 

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
 

Sample Input
  
  
5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10
 

Sample Output
  
  
11 13 27
题意:在图里减去某一条边,问最长的最短路是多少?

思路:对于不在原最短路上的边,减去后最短路不变,所以我们只需枚举最短路上的边,每次求一次最短路,取最长的一个即可

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
#define N 1010
#define M N*(N-1)/2
#define INF 100000000
int n,m;
int ma[N][N];
int vis[N],d[N];
int pre[N];
void init()
{
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            ma[i][j]=INF;
}
void djstl(int s,int t)
{
    for(int i=1;i<=n;i++)
    {
        d[i]= i==s?0:ma[s][i];
        vis[i]=(i==s);
        if(t==0) pre[i]=s;
    }
    for(int i=1;i<n;i++)
    {
        int maxn=INF;int v=-1;
        for(int j=1;j<=n;j++)
            if(!vis[j]&&maxn>d[j])
            {
                maxn=d[j];
                v=j;
            }
        if(v==-1) continue;
        vis[v]=1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&d[v]+ma[v][j]<d[j])
                {
                    d[j]=d[v]+ma[v][j];
                    if(t==0) pre[j]=v;
                }
        }
    }
}
int main()
{
    int s,t,w;
    while(~scanf("%d %d",&n,&m))
    {
        init();
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d",&s,&t,&w);
            if(w<ma[s][t])
            ma[s][t]=ma[t][s]=w;
        }
        djstl(1,0);
        int maxn=d[n];
        for(int i=n;i!=1;i=pre[i])
        {
                int v=ma[i][pre[i]];
                ma[i][pre[i]]=ma[pre[i]][i]=INF;
                djstl(1,1);
                maxn=max(maxn,d[n]);
                ma[i][pre[i]]=ma[pre[i]][i]=v;
        }
        printf("%d\n",maxn);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值