HDU1595:find the longest of the shortest(Dijkstra)

Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn't live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn't konw exactly which road. It is possible to come from Marica's city to Mirko's no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.
 

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.
 

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.
 

Sample Input
  
  
5 6 1 2 4 1 3 3 2 3 1 2 4 4 2 5 7 4 5 1 6 7 1 2 1 2 3 4 3 4 4 4 6 4 1 5 5 2 5 2 5 6 5 5 7 1 2 8 1 4 10 2 3 9 2 4 10 2 5 1 3 4 7 3 5 10
 

Sample Output
  
  
11 13 27
 


 

题意:城市内有n条路,其中有某条路在修,因为这条路有很多情况,问各种情况下的最短路中最长的是哪条

思路:直接枚举所有情况算出最大值即可

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int inf = 999999999;
int map[1005][1005];
int vis[1005],dis[1005],link[1005];
int n,m;

void Dijkstra(int s,int flag)
{
    int i,j,minn,pos;
    memset(vis,0,sizeof(vis));
    for(i = 0; i<=n; i++)
        dis[i] = inf;
    dis[s] = 0;
    for(i = 1; i<=n; i++)
    {
        minn = inf;
        for(j = 1; j<=n; j++)
        {
            if(dis[j]<minn && !vis[j])
                minn = dis[pos = j];
        }
        vis[pos] = 1;
        for(j = 1; j<=n; j++)
            if(dis[pos]+map[pos][j]<dis[j])
            {
                dis[j] = dis[pos]+map[pos][j];
                if(flag)//只记录最短哪条路径的父节点
                    link[j] = pos;
            }
    }
}

int main()
{
    int i,j,x,y,w;
    while(~scanf("%d%d",&n,&m))
    {
        for(i = 0; i<=n; i++)
        {
            for(j = 0; j<=n; j++)
                map[i][j] = inf;
            map[i][i] = 0;
        }
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&w);
            if(w<map[x][y])
                map[x][y] = map[y][x] = w;
        }
        memset(link,0,sizeof(link));
        Dijkstra(1,1);
        int ans = dis[n];
        for(i = n; i!=1; i=link[i])
        {
            int tem = map[i][link[i]];
            map[i][link[i]] = map[link[i]][i] = inf;
            Dijkstra(1,0);
            ans = max(ans,dis[n]);
            map[i][link[i]] = map[link[i]][i] = tem;
        }
        printf("%d\n",ans);
    }

    return 0;
}


 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值