【二分匹配】 poj2060 Taxi Cab Scheme

Taxi Cab Scheme

Description

Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible,there is also a need to schedule all the taxi rides which have been booked in advance.Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides. 
For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest,at least one minute before the new ride's scheduled departure. Note that some rides may end after midnight.

Input

On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time.

Output

For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.

Sample Input

2
2
08:00 10 11 9 16
08:07 9 16 10 11
2
08:00 10 11 9 16
08:06 9 16 10 11

Sample Output

1
2

题意:给出乘客的起始时间,起点和目的地的坐标,求最少要几辆的士能满足所有的乘客的出行。


#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 505
#define abs(x) ((x)>0?(x):(-(x)))
//这里的括号一定不能省
int time[MAX],pos[MAX][4];
bool path[MAX][MAX],visit[MAX];
int match[MAX];
bool SearchPath(int s,int m)
{
    for(int i=0; i<m; ++i)
    {
        if(path[s][i]&&!visit[i])
        {
            visit[i]=true;
            if(match[i]==-1||SearchPath(match[i],m))
            {
                match[i]=s;
                return true;
            }
        }
    }
    return false;
}
int distants(int a,int b,int c,int d)
{
    return (abs(a-c)+abs(b-d));
}
int main()
{
    int T,n,a,b;
    scanf("%d",&T);
    for(;T--;)
    {
        scanf("%d",&n);
        memset(path,false,sizeof(path));
        for(int i=0;i<n;++i)
        {
            scanf("%d:%d",&a,&b);
            time[i]=a*60+b;
            for(int j=0;j<4;++j)
                 scanf("%d",&pos[i][j]);
        }
        for(int i=0;i<n;++i)
        {
            for(int j=i+1;j<n;++j)
            {
                if(time[i]+distants(pos[i][0],pos[i][1],pos[i][2],pos[i][3])+distants(pos[i][2],pos[i][3],pos[j][0],pos[j][1])<time[j])
                    path[i][j]=true;
            }
        }
        int summ=0;
        memset(match,-1,sizeof(match));
        for(int i=0; i<n; ++i)
        {
            memset(visit,false,sizeof(visit));
            if(SearchPath(i,n))
                summ++;
        }
        printf("%d\n",n-summ);
    }
    return 0;
}

来源: http://blog.csdn.net/acm_ted/article/details/7780079

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值