HDOJ1671 Phone List(优化算法)

 Description
 输入的号码中如果有任意一个号码是另一个号码的前缀,只能拨通最短的那个号码,所以输出NO,否则输出YES。
      

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input

    
    
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
         

Sample Output

       
       
NO YES
        
 思路:所有号码按照字典序进行排序,(sort函数可以实现字典排序),然后遍历所有数,看前一个数是否是后一个数的前缀

 注意:

定义string s[100];

输入不能用 scanf("%s", s[i]);和strlen(s[i])

因为string类型不是单纯的字符串,不能用%s表示,而string里面应该放的是字符串的名字,

输入改成  cin>>s[i];就对了

求长度要用s.length(),或者s.size()。

 

对于string类型也不能用sizeof(s[0]);这样的话无论怎样,输出结果都是一样的。

 

如果对定义的字符串数组string s[100]按照字典序排序,可以用sort(s, s+n);

c++里面定义string变量用的应该是#include<string>。


#include <stdio.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
string s[10010];
bool judge(int n)
{
    int len, i, j;
    for(i = 0; i < n-1; i++)
    {
        len = s[i].size();
       
        for(j = 0; j < len; j++)
        {
            if(s[i][j] != s[i+1][j])
            {
              
                break;
            }
        }
      
        if(j == len)
            return true;
    }
    return false;
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n;
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
            cin >> s[i];
        sort(s, s+n);
        
        if(judge(n))
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值