(字典树)Phone List--HDOJ

Phone List
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 324 Accepted Submission(s): 128

Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

Source
2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(3)

Recommend
lcy

/*
    由于没有释放内存,内存超了
    由于没有用c数组读入,时间超了
    ...
*/
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string>
#include<string.h>
#include<math.h>
#include<map>
#include<set>
#include<string>
#define mod 1000000007

using namespace std;

typedef struct Node
{
    bool is;
    Node *nxt[11];
    Node()
    {
        is = false;//is为true,则代表一个单词的结束
        memset(nxt,0,sizeof(nxt));
    }
}Node;
char word[10001][11];//用string读入会超时的
void Insert(Node * root,string s)
{

    int indx=0;
    Node *p = root;
    while(indx<s.size())
    {
        int k = s[indx++] - '0';
        if(p->nxt[k] == 0)
            p->nxt[k] = new Node();
        p = p->nxt[k];
    }
    p->is = true;
}
bool Search(Node *root,string s)
{
    Node *p = root;
    int indx = 0;
    while(indx < s.size())
    {
        int k = s[indx++] - '0';
        p = p->nxt[k];
    }
    for(int i=0; i<=9; ++i)
    {
        if(p->nxt[i])
            return 1;
    }
    return 0;
}
void Del(Node *root)
{
    for(int i =0;i<=9;i++)
    {
        if(root->nxt[i])
                Del(root->nxt[i]);
    }
    free(root);
}
int main(void)
{
 //   freopen("in.txt","r",stdin);
    int ncase;
    cin >> ncase;
    while(ncase--)
    {
        int n,indx=0;
        Node *root = new Node();

        scanf("%d",&n);
        while( indx < n )
        {
            scanf("%s",word[indx]);
            Insert(root,word[indx]);//建树
            indx++;
        }

        int flg = 1;
        for(int i=0; i<n; ++i)
        {
            string s = word[i];
            if(Search(root,s))
            {
                flg = 0;
                break;
            }
        }
        if(flg)
            cout << "YES"<<endl;
        else
            cout << "NO"<<endl;

        Del(root);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值