HDOJ 1671 Phone List (字典树+释放空间)

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15218    Accepted Submission(s): 5136


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 

题意:给你n个电话号码,能不能根据一个索引找到一个人

思路:其实就是查看n个串之间是否存在子串关系,以最长串为第一个串,然后用后面的串和其相比
另外,最后不能忘了释放空间,不然会超内存


ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stack>
#include<iostream>
#include<algorithm>
#define fab(a) (a)>0?(a):(-a)
#define LL long long
#define MAXN 10010
#define mem(x) memset(x,0,sizeof(x))
#define INF 0xfffffff 
using namespace std;
struct s
{
	int num;
	s *next[10];
};
struct word
{
	char phone[12];
	int len;
}a[MAXN];
s *root;
bool cmp(word q,word w)
{
	return q.len<w.len;
}
void create(char *str)
{
	int len=strlen(str);
	s *p=root,*q;
	for(int i=0;i<len;i++)
	{
		int id=str[i]-'0';
		if(p->next[id]==NULL)
		{
			q=(s *)malloc(sizeof(s));
			q->num=1;
			for(int j=0;j<10;j++)
			q->next[j]=NULL;
			p->next[id]=q;
			p=p->next[id];
		}
		else
		{
			p->next[id]->num++;
			p=p->next[id];
		}
	}
	//p->num=-1;
}
int find(char *ss)
{
	int len=strlen(ss);
	s *p=root;
	for(int i=0;i<len;i++)
	{
		int id=ss[i]-'0';
		p=p->next[id];
		if(p==NULL)
		return 0;
//		if(p->num==-1)
//		return -1;
	}
	return p->num;
}
void begin()
{
	for(int i=0;i<10;i++)
	root->next[i]=NULL;
}
void freetree(s *t)
{
	if(t==NULL)
	return;
	for(int i=0;i<10;i++)
	{
		if(t->next[i]!=NULL)
		freetree(t->next[i]);
	}
	free(t);
	return;
}
int main()
{
	
	int t,i,n;
	scanf("%d",&t);
	while(t--)
	{
		int bz=0;
		root=(s *)malloc(sizeof(s));
		begin();
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%s",a[i].phone);
			int l=strlen(a[i].phone);
			a[i].len=l;
		}
		sort(a,a+n,cmp);
		create(a[n-1].phone);
		for(i=n-2;i>=0;i--)
		{
			if(find(a[i].phone)==0)
			create(a[i].phone);
			else
			{
				bz=1;;
				break;
			}
		}
		printf(bz?"NO\n":"YES\n");
		freetree(root);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值