Phone List
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14670 Accepted Submission(s): 4946
Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES
还是熟悉trie模板,注意要随时清内存
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cstdlib>
//#define LOCAL
using namespace std;
typedef struct trie{
int v;
struct trie* next[10];
}Trie;
Trie* root;
char str[15];
void createTrie(char* T);
bool findTrie(char* str);
void deal(Trie* T);
int main()
{
#ifdef LOCAL
freopen("data.in","r",stdin);
#endif // LOCAL
int N;
scanf("%d",&N);
while(N--){
int n;
scanf("%d",&n);
int i,j;
root = (Trie*)malloc(sizeof(Trie));
for(i = 0;i<10;i++)
root->next[i] = NULL;
bool p = false;
for(i = 0;i<n;i++){
scanf("%s",str);
if(!p&&findTrie(str)){
p = true;
}
if(p)
continue;
createTrie(str);
}
if(p)
printf("NO\n");
else
printf("YES\n");
deal(root);
}
return 0;
}
bool findTrie(char* str){
int len = strlen(str);
Trie* p = root;
for(int i = 0;i<len;i++){
int id = str[i] - '0';
p = p->next[id];
if(p == NULL)
return false;
if(p->v == -1)
return true;
}
return true;
}
void deal(Trie* T){
int i;
if(T==NULL)
return;
for(i = 0;i<10;i++)
if(T->next[i]!=NULL)
deal(T->next[i]);
free(T);
}
void createTrie(char* str){
Trie* p = root,*q;
int len = strlen(str);
int i;
for(i = 0;i<len;i++){
int id = str[i] - '0';
if(p->next[id] == NULL){
q = (Trie*)malloc(sizeof(Trie));
q->v = 1;
for(int j = 0;j<10;j++)
q->next[j] = NULL;
p->next[id] = q;
}else
p->next[id]->v++;
p = p->next[id];
}
p->v = -1;
}