POJ 3069 Saruman's Army

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range ofR units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integerR, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integern, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positionsx1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case withR = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.


/*
POJ 3069
用一个半径为r的圆去覆盖一条直线上的点。每个圆内必须有至少一个被标记的点(标记点为圆心)。问最少需要标记多少个点。

第一行输入半径r,与直线上点的个数n。(输入-1 -1 结束程序)
第二行输入n个点的值。
输出最少需要标记点的个数。

input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

output
2
4
*/
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

bool cmp(int a,int b){
   return a<b;
}

int a[1005];
int main(){
    int r,n,i,left,right,ans;
    while(cin >>r >>n){
        if(r == -1 &&n == -1)   //结束条件;
            break;
        for(i = 0;i < n;i++)    //输入并排序;
            cin >>a[i];
        sort(a,a+n);
        ans = 1;    //标记第一个点;
        left = a[0],right = a[0] + r;   //设第一个点为圆心的圆的左右边界;
        for(int i = 1;i<n;i++){
            if(a[i] - r <= left){   //如果前面的点在这个点的圆里,标记这个点,取消前面点的标记。标记点的数量不变;
                right = a[i] + r;
            }
            else if(right < a[i]){  //若不在,则标记这个点,ans++,并添加新圆,更新对照的左右边界;
                ans++;
                left = a[i];
                right = a[i] + r;
            }
        }
        cout <<ans <<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值