Saruman's Army(贪心)——区间问题

刚接触到区间问题这样的贪心题目,写篇博客记录一下

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input
The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output
For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output
2
4
Hint
In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题意:
有一支军队分成若干个小部队分布在不同的位置,现有一种最大半径为R的石头可以掩护士兵,问最少可以用多少个这样的石头可以把整支部队掩护起来。

再来看:
在这里插入图片描述
在这里插入图片描述

代码:

#include<iostream>
#include<algorithm>
using namespace std;
int s[1000+10];
int i,j;  //控制循环
int sum;  //最少的数量
int n,r;
int temp,item;
int main()
{
  while(cin>>r>>n)
  {
    if(r==-1&&n==-1)
     break;
    for(i=0;i<n;i++)
     cin>>s[i];
    sort(s,s+n);
    while(j<n)
    {
      temp=s[j++];  //temp是没有被覆盖的最左的点的位置
      while(j<n&&s[j]<=temp+r)
       j++;    //一直向右直到距temp的距离大于R的点
      j--;
      item=s[j];      //新加上的被标记的点
      while(j<n&&s[j]<=item+r)
       j++;          //一直向右到能够覆盖到的最远的点
      sum++;
    }
    cout<<sum<<endl;
    sum=j=0;
  }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值