1085. Perfect Sequence (25)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:

8


IDEA

1.首先不要把问题想的太简单,传统的方法是不可行的:即序列从小到大,min_index,max_index,min_index从左向右,max_index从右向左找

会超时啊!!!

2.可以固定一个,用二分法找另外一个(即min_index从左到右,max_index采用二分法查找)

3.还有解决办法是贪心(看到别人的)


CODE

#include<iostream>
#include<fstream>
#include<algorithm>
#include<vector>
using namespace std;
int main(){
	//freopen("input.txt","r",stdin);
	int n;
	double p;
	cin>>n>>p;
	vector<long long> seq;
	for(int i=0;i<n;i++){
		long long num;
		cin>>num;
		seq.push_back(num);
	}
	sort(seq.begin(),seq.end());

//二分查找
	int count=0;
	int up,down=1;
	for(int min_index=0;min_index<n;min_index++){
		long long tmp=seq[min_index]*p;
		if(tmp>=seq[n-1]){
			if(count<n-min_index){
				count=n-min_index;
			}
			break;
		}
		up=n-1;
		while(down<up){
			int mid=(down+up)/2;
			if(seq[mid]>tmp){
				up=mid;
			}else if(seq[mid]<tmp){
				down=mid+1;
			}else{
				down=mid+1;
				break;
			}
		}
		if(count<down-min_index){
			count=down-min_index;
		}
	} 
	cout<<count;
/*
//贪心 
	int min_index=0,max_index=0;
	int count=0;
	while(1){
		while(max_index<n&&seq[max_index]<=seq[min_index]*p){
			max_index++;
		}
		if(count<max_index-min_index){
			count=max_index-min_index;
		}
		if(max_index==n){
			break;
		}
		while(min_index<max_index&&seq[min_index]*p<seq[max_index]){
			min_index++;
		}
	}
	cout<<count;
*/
	//fclose(stdin);
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值