PAT 1036. Boys vs Girls (25)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA

思路:在给出的学生信息中选出分数最低的男生,分数最高的女生,两者都存在的话,输出名字和id,两者分数差。如果有缺的输出Absent,此时没有分数差。
#include<iostream>
#include<string>
#include<fstream>

using namespace std;

struct stu
{
	string s;
	char c;
	string id;
	int score;
};

int main()
{
	//ifstream cin("in.txt");
	int n;
	while (cin >> n)
	{
		stu t, t1, t2;
		t1.score = -1;
		t2.score = 200;
		while (n--)
		{
			cin >> t.s >> t.c >> t.id >> t.score;
			if (t.c == 'F') //是女生,找出其中分数最高的
			{
				if (t.score > t1.score)
				{
					t1.s = t.s;
					t1.id = t.id;
					t1.score = t.score;
				}
			}
			else  //男生,找出其中分数最低的
			{  
				if (t.score < t2.score)
				{
					t2.s = t.s;
					t2.id = t.id;
					t2.score = t.score;
				}
			}
		}
		if (t1.score == -1)  //没有男生
			cout << "Absent" << endl;
		else
			cout << t1.s << " " << t1.id << endl;
		if (t2.score == 200)  //没有女生
			cout << "Absent" << endl;
		else
			cout << t2.s << " " << t2.id  << endl;
		if (t1.score ==-1 || t2.score==200)
			cout << "NA" << endl;
		else
			cout << t1.score - t2.score << endl; //分数差
	}
	//system("pause");
	return 0;
}





 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值