1036. Boys vs Girls (25)

102 篇文章 0 订阅
4 篇文章 0 订阅

1036. Boys vs Girls (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF-gradeM. If one such kind of student is missing, output "Absent" in the corresponding line, and output "NA" in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA
输入N,接着N行,M找成绩最低,F找成绩最高
如果两者都都有,输出两者的名字和ID ,并输出F的成绩减M的成绩
两者缺的话缺的输出Absent,并输出NA

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月04日 15:55答案正确251036C++ (g++ 4.7.2)1308datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确130010/10
1答案正确13085/5
2答案正确13045/5
3答案正确13085/5

#include<iostream>   
#include<string>
using namespace std;  
struct Consuming
{
  string name ;
  string ID ; 
  int grade;
  bool mark;
  Consuming(bool mar):mark(mar){}
  Consuming(string nam, string I, int gra, bool t) :name(nam), ID(I), grade(gra), mark(t) { }
}; 
int main()
{  
  int N,grade;
  string name;
  string ID;
  char M_or_F;
  Consuming Male = { false }, Female = {false};
  cin >> N;
  while (N--)
  {
    cin >> name >> M_or_F >> ID >> grade;
    if ('M' == M_or_F)
    {
      if (Male.mark&&Male.grade > grade)
        Male = Consuming(name, ID, grade,true);
      else if (!Male.mark) 
        Male = Consuming(name, ID, grade,true);  
    }
    else if ('F' == M_or_F)
    {
      if (Female.mark&&Female.grade<grade)
        Female = Consuming(name, ID, grade,true);
      else if (!Female.mark) 
        Female = Consuming(name, ID, grade,true);   
    }
  }
  if (Female.mark)cout << Female.name << " " << Female.ID << endl;
  else cout << "Absent" << endl;
  if (Male.mark)cout << Male.name << " " << Male.ID << endl;
  else cout << "Absent" << endl;
  if (Female.mark&&Male.mark) 
    cout << Female.grade - Male.grade << endl;   
  else cout << "NA" << endl;
  system("pause");
  return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值