PAT 1025. PAT Ranking (25)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

思路:有多组学生,结果是要输出总学生数,然后是这些学生的信息,id ,在整个大组最终排名,组号,在自己小组的排名。 我们可以在输入每个组数据时,先进行排序,确定小组排名
     然后把结果储存起来,到最后跟其他小组一起排序,确定出最终排名。
#include <vector>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <string>
using namespace std;

struct Student  {
	string id;
	int score;
	int fr, g, gr;
};

bool comp (const Student &s1, const Student &s2)
{
	if (s1.score == s2.score) //分数相同的,名字排序
		return s1.id < s2.id;
	else
	    return s1.score > s2.score;
}

int main()
{
   //ifstream cin("in.txt");
	int n, m;
	cin >> n;
	vector<Student> vs, vt;
	for (int i = 1; i<=n; ++i) {
		vs.clear();
		cin >> m;   //输入每一小组学生信息
		while (m--) {
			Student stu;
			cin >> stu.id >> stu.score;
			stu.g = i;  //组号
			vs.push_back(stu);
		}
		sort (vs.begin(), vs.end(), comp);
		vs[0].gr = 1;  //每一组进行排序,确定组排名
		for (int i=1; i!=vs.size(); ++i) 
			if (vs[i].score == vs[i-1].score) 
				vs[i].gr = vs[i-1].gr;
			else
				vs[i].gr = i+1;
		vt.insert(vt.end(), vs.begin(), vs.end()); //结果存储起来
	}
	cout << vt.size() << endl;//对全部组进行排序,确定最终排名
	sort (vt.begin(), vt.end(), comp);
	vt[0].fr = 1;
	for (int i=1; i!=vt.size(); ++i) 
		if (vt[i].score == vt[i-1].score) 
			vt[i].fr = vt[i-1].fr;
		else
			vt[i].fr = i+1;
	
	for (int i=0; i!=vt.size(); ++i)
		cout << vt[i].id << " " << vt[i].fr << " "
		     << vt[i].g  << " " << vt[i].gr << endl;
	system("pause");
	return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值