Expanding Rods--二分答案

Expanding Rods
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 15096 Accepted: 4009

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is  displaced (取代)

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000

题目链接:http://poj.org/problem?id=1905


又一道二分答案,好吧,我看得题解,用到的完全是高中数学的知识。我又傻了。。。


题意是说一根某种材料做的直杆被夹在两面墙之间,当他受热时长度会变长,就会因两面墙的挤压而向上隆起。长度变化函数为 L'=(1+n*C)*L,给定L,C,n,求向上拱起的高度H。


\

膨胀后变成一段弧 也就是圆的一部分 原来的棍子就变成了圆的截线。。。这不是高中很常见的图么。。。

这样做几条辅助线 从圆心做截线的垂线延长到弧 设棍子原长L 膨胀后(弧)长s 膨胀后中点与原中点距离h 半径r 半径与圆心到截线垂线的夹角θ 可以得到以下三个公式

sinθ = (L/2)/r

r^2 = (r-h)^2+(L/2)^2

s/(2*π*r) = (2*θ)/(2*π)

然后化简下 可得 

θ = asin((L/2)/r)

r = ( L^2/(8*h) + h/2)

s = 2*θ*r = 2*asin((L/2)/r)*(L^2/(8*h) + h/2)


仔细想想,这个题也不是很难,不要直接去求h,会有精度问题,还有一件事,我吃过好多次亏了

在poj上输出要用%f!!!!

在poj上输出要用%f!!!!

在poj上输出要用%f!!!!

吃了这么多次亏还犯,还傻呵呵的去找了好长时间的bug,猪脑子啊!


代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
#define eps 1e-7
using namespace std;
int main()
{
    double len,n,c;
    while(~scanf("%lf%lf%lf",&len,&n,&c))
    {
        if(len<0||n<0||c<0)
            break;
        double s=(1+n*c)*len;
        double minc=0;
        double maxc=len/2;
        double h;
        while(maxc-minc>eps)//不要写while(maxc>minc) 会死循环TAT
        {
            h=(minc+maxc)/2;
            double r=(len/2)*(len/2)/(2*h)+h/2;//半径
            if(asin(len/(2*r))*r*2<s)//s
                minc=h;
            else
                maxc=h;
        }
        printf("%.3f\n",h);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值