poj1573——Robot Motion(模拟)

Description

这里写图片描述

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word “step” is always immediately followed by “(s)” whether or not the number before it is 1.
Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0
Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

题意就是按照图中给的方位上下左右移动,如果能出去就输出走了多少步,如果陷入循环,就输出在循环前走了多少步和循环了多少步。
按照题意模拟就行,先是边走边标记,记步数,如果走出去了,直接输出步数就行。如果没有,则在循环的这个点,按照标记走,边走边抹除标记,并计步数,直到没有标记为止。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <map>
#include <algorithm>
#include <stack>
#define INF 0x3f3f3f3f
#define MAXN 100010
#define Mod 10001
using namespace std;
char grid[20][20];
int vis[20][20];
int main()
{
    int r,c,e;
    while(cin>>r>>c>>e)
    {
        if(r==0&&c==0&&e==0)
            break;
        memset(vis,0,sizeof(vis));
        for(int i=1; i<=r; ++i)
        {
            vis[i][0]=1;
            vis[i][c+1]=1;
        }
        for(int i=1; i<=c; ++i)
        {
            vis[0][i]=1;
            vis[r+1][i]=1;
        }
        for(int i=1; i<=r; ++i)
            for(int j=1; j<=c; ++j)
                cin>>grid[i][j];
        int x=1,y=e,sum1=0;
        while(!vis[x][y])
        {
            if(!vis[x][y]&&grid[x][y]=='N')
            {
                vis[x][y]=1;
                x--;
                sum1++;
            }
            else if(!vis[x][y]&&grid[x][y]=='S')
            {
                vis[x][y]=1;
                x++;
                sum1++;
            }
            else if(!vis[x][y]&&grid[x][y]=='W')
            {
                vis[x][y]=1;
                y--;
                sum1++;
            }
            else if(!vis[x][y]&&grid[x][y]=='E')
            {
                vis[x][y]=1;
                y++;
                sum1++;
            }
        }
        if(x<1||x>r||y<1||y>c)
            printf("%d step(s) to exit\n",sum1);
        else
        {
            int sum2=0;
            while(vis[x][y])
            {
                if(vis[x][y]&&grid[x][y]=='N')
                {
                    vis[x][y]=0;
                    x--;
                    sum2++;
                }
                else if(vis[x][y]&&grid[x][y]=='S')
                {
                    vis[x][y]=0;
                    x++;
                    sum2++;
                }
                else if(vis[x][y]&&grid[x][y]=='W')
                {
                    vis[x][y]=0;
                    y--;
                    sum2++;
                }
                else if(vis[x][y]&&grid[x][y]=='E')
                {
                    vis[x][y]=0;
                    y++;
                    sum2++;
                }
            }
            printf("%d step(s) before a loop of %d step(s)\n",sum1-sum2,sum2);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值