poj2187——Beauty Contest(凸包+旋转卡壳)

Description

Bessie, Farmer John’s prize cow, has just won first place in a bovine beauty contest, earning the title ‘Miss Cow World’. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 … 10,000. No two farms share the same pair of coordinates.

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms.

Input

  • Line 1: A single integer, N

  • Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm
    Output

  • Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other.
    Sample Input

4
0 0
0 1
1 1
1 0
Sample Output

2

给出一些坐标,求其中最远的两个点之间的距离
旋转卡壳学习http://www.cnblogs.com/xdruid/archive/2012/07/01/2572303.html

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 50005
#define Mod 10001
using namespace std;
struct point
{
    int x,y;
} p[MAXN];
int top,n,s[MAXN];
int cross(point a,point b,point c)//叉积
{
    return (b.x - a.x) * (c.y - a.y) - (c.x - a.x) * (b.y - a.y);
}

int dis(point a,point b)//距离
{
    return (a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y);
}

bool cmp(point a,point b)
{
    int ans = cross(p[0],a,b);
    if( ans > 0 || (ans == 0 && dis(p[0],a) > dis(p[0],b) )) return true;
    return false;
}

void graham()//凸包模板。。
{
    s[0] = 0;
    s[1] = 1;
    top = 1;
    for(int i = 2; i != n ; i ++)
    {
        while(top && cross(p[s[top - 1]],p[s[top]],p[i] ) < 0) top--;
        s[++top] = i;
    }
    top ++;
}

void RC()//旋转卡壳
{
    int q,ans = 0;
    q = 1;
    ans = dis(p[s[0]],p[s[1]]);
    for(int i = 0; i != top ; i ++)
    {
        while(abs(cross(p[s[(i+1)%top]],p[s[i%top]],p[s[(q+1)%top]])) > abs(cross(p[s[(i+1)%top]],p[s[i%top]],p[s[q%top]])))
            q = (q + 1)%top;
        ans = max(ans, max(dis(p[s[(i+1)%top]],p[s[q]]),dis(p[s[i%top]],p[s[q]])));
    }
    printf("%d\n",ans);
}

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i =0 ; i != n; i ++)
            scanf("%d%d",&p[i].x,&p[i].y);
        int u = 0;
        for(int i = 1; i != n; i ++) //寻找基点
        {
            if(p[u].y > p[i].y || (p[u].y == p[i].y && p[u].x > p[i].x))
                u = i;
        }
        if(u)
        {
            swap(p[u].y,p[0].y);
            swap(p[u].x,p[0].x);
        }
        sort(p + 1,p + n,cmp);
        graham();
        RC();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值