poj-1730 Perfect Pth Powers

                                                                        J - Perfect Pth Powers
Crawling in process... Crawling failed Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

Description

We say that x is a perfect square if, for some integer b, x = b 2. Similarly, x is a perfect cube if, for some integer b, x = b 3. More generally, x is a perfect pth power if, for some integer b, x = b p. Given an integer x you are to determine the largest p such that x is a perfect p th power.

Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the largest integer p such that x is a perfect p th power.

Sample Input

17
1073741824
25
0

Sample Output

1
30
2
这题是要求我们求最大的平方数,按照正规的方法可能会比较难些,那我们就反着做,先求出他能开多少次方,然后在平方,求出最大的平方数。
#include <iostream>
#include <algorithm>
#include <cmath>
#include<cstdio>
#define EPS 1e-5
using namespace std;
int pow(int a,int b)
{ 
	int ans=1; 
	while(b--) 
		ans*=a; 
	return ans;
}
int main()
{
	int n;
	while(~scanf("%d", &n) && n)
	{  
		int t=1;  
		int i,ans=1;  
		if(n<0) t=-1;  
		for(i=2; i<32; i++) 
		{   
			int tmp=(long long)(pow(n*1.0*t,1.0/i)+EPS)*t;   
			if(pow(tmp,i)==n) 
				ans=i;  
		}  
		printf("%d\n",ans);
	} 
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值