Area

D - Area
Crawling in process... Crawling failed Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input

4
5
825
6725
6244865

Sample Output

0
0
0.5
2
这题使用叉积来计算面积。先定义一个数组来存储坐标的变化。然后根据提供的数据进行坐标的变化及计算。
#include<iostream>
using namespace std;
#include<cstdio>
__int64 dic[10][2]={{0,0},{1,-1},{1,0},{1,1},{0,-1},{0,0},{0,1},{-1,-1},{-1,0},{-1,1}};
__int64 Get2Area(__int64 x1,__int64 y1,__int64 x2,__int64 y2)
{
    return (x1*y2-x2*y1); 
}
int main()
{
    int n,p;char c;
    __int64 x1=0,x2=0,y1,y2,area=0; 

    cin>>n;
    while(n--)
    {
        while((c=cin.get())!='5') 

        {
            p=c-'0';
            x2=x1+dic[p][0];
            y2=y1+dic[p][1];
            area+=Get2Area(x1,y1,x2,y2); 
            x1=x2;
            y1=y2;
        }
        if(area<0)area=(-1)*area;
        x2=area/2;
        if(area!=x2*2)
		{
			printf("%I64d.5\n",x2);
		} 
        else
		{
		    printf("%I64d\n",x2);
		}
        area=0;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值