POJ_1129 pie 解题报告

 
                                                                                                         J - Pie
      Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
 

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

 

这是一道关于生日的时候分饼的问题。要求是每个人分到的饼的体积要相同,并且只能由一块大饼分成小饼,而不能是几块小饼拼凑成一块大的。题目先输入一个数表示一共有多少组数据,然后输入两个整数表示饼的个数和朋友的人数,再接着输入每个饼的半径。我们要求的是每个人可以分到的最大的饼的体积。要注意的是计算人数的时候一定要加上自己当看到这道题目的时候我的第一想法是通过将饼的大小进行排序,在根据人数的多少从大到小的顺序进行分饼,这就要判断每个饼分到人后的体积与下一个饼的体积的比较,还有体积的计算都不好算。后来我到网上找了思路才知道这道题目用二分法做比较简单。先求出每个人能分到的最大的体积,即总体积除以总人数,然后对每个人将要分到的体积进行二分,将每个饼除以这个体积求出这些饼可以分成多少人,若此人数大于总人数就扩大二分法的左边值继续进行二分,反之就减小二分法的右值在进行二分,最后求出分到的最大体积。

#include<iostream>
#include <cmath>
using namespace std;
int A,B;
double V[10000];//用于记录每个饼的体积。
double pi = acos ( -1.0 );//精确求pi的值。
int test(double mid)//二分的测试过程。
{
	int num=0;
	int i;
	for(i=0;i<A;i++)
	{
		num+=V[i]/mid;//求饼可以分成的总人数.
	}
	if(num>B)
		return 1;
	else
		return 0;
}
int main()
{
	int i,N,r;
	double v,R,L,mid;
	scanf("%d",&N);
	while(N--)
	{
		v=0;
		scanf("%d%d",&A,&B);
		for(i=0;i<A;i++)
		{
			scanf("%d",&r);
			V[i]=r*r*pi;
			v+=V[i];
		}
		L=0;
		R=v/(B+1);//计算每个人可分到的最大体积数。
		while((R-L)>1e-6)
		{
			mid=(R+L)/2;
			if(test(mid)==1)
				L=mid;
			else
				R=mid;
		}
		printf("%.4lf\n",mid);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值