POJ 1328 Radar Installation (贪心+线段覆盖)

3 篇文章 0 订阅
Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 77865 Accepted: 17424

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

Beijing 2002


题意:海上有n个岛,x轴上的雷达的范围为d, 问覆盖所有岛屿最少需要多少雷达。

如果abs(y)>d,则返回-1.

思路:以岛为中心作半径为d的圆,交x轴于两点成一条线段,排序各个线段,若第i个线段的l>第i-1个线段的r  则说明前一个雷达并不能覆盖此岛屿,需要新建设雷达。

代码好像大概会RE。但是思想正确。。就这么放着吧- -

#include <cstdio>  
#include <cstring>  
#include <cmath>  
#include <cstdlib>  
#include <algorithm>  
#include <queue>  
#include <stack>  
#include <map>  
#include <vector>
#include <iostream>
#define INF 0x3f3f3f3f  
#define eps 1e-4  
#define MAXN (1000+10)  
#define MAXM (1000000)  
#define CLR(a, b) memset(a, (b), sizeof(a))  
#define MOD 100000007  
#define LL long long  
#define lson node<<1, l, mid  
#define rson node<<1|1, mid+1, r   
using namespace std;
int xy[MAXN][MAXN];
struct line
{
	double l, r;
}l[MAXN],temp;

//sort函数需要重载“<”,以升序排列
bool operator < (line a, line b) {
	return a.l < b.l;
}

int main() {
	int n, d,cnt=1;
	double x, y;
	while (scanf("%d%d",&n,&d) && (n || d)) {
		bool flag = true;
		for (int i = 1; i <= n; ++i) {
			scanf("%d%d", &x, &y);
			if (abs(y) > d) flag = false;
			else {
				l[i].l = x*1.0 - sqrt(d*d - y*y);
				l[i].r = x*1.0 + sqrt(d*d - y*y);
			}
		}
		cout << "Case " << cnt++ << ": ";
		if (!flag) {
			cout << -1 << endl;
		}
		else {
			temp = l[1];
			int ans = 1;
			sort(l, l + n);
			for (int i = 2; i <= n; ++i) {
				if (l[i].l > temp.r) {
					ans++;
					temp = l[i];
				}
				else if (temp.r > l[i].r) {
					temp = l[i];
				}
			}
			cout << ans << endl;
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值