[HDU 2955 Robberies] 入门DP

15 篇文章 0 订阅
6 篇文章 0 订阅

题目连接  http://acm.hdu.edu.cn/showproblem.php?pid=2955

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16598    Accepted Submission(s): 6101


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6
 

Source
IDI Open 2009


入门DP(正适合我这种菜鸡。。),题意告诉你小偷不能忍受的被捕概率和几个银行,接下来是每个银行的价值和被抓概率;
一开始把概率当做背包容量相加了。。错了好久,对不起高中数学老师。。
若抢劫A银行被抓概率为p1,抢劫B银行被抓概率为p2,那么抢劫A和B银行被抓概率应该为1-(1-p1)*(1-p2)
而dp储存的是当前价值的逃生几率,那么可以推出动态方程dp[j]=max(dp[i],dp[i-val[i]]*(1-p[i]))

那么代码如下。。


#include<stdio.h>
#include<string.h>
double max(double a, double b)
{
	return a > b ? a : b;
}
typedef struct node
{
	int dis;
	double p;
};
node nod[101];
int t;
double dp[10010];
int main()
{
//	freopen("input.txt", "r", stdin);
	int sum, m;
	double p;
	scanf("%d", &t);
	while (t--)
	{
		memset(dp, 0, sizeof(dp));  //初始化
		dp[0] = 1;   //抢劫0元的逃生概率为1,这个必须要写
		sum = 0;

		scanf("%lf%d", &p, &m);
		for (int i = 0; i < m; i++)
		{
			scanf("%d%lf", &nod[i].dis, &nod[i].p);
			sum += nod[i].dis;
		}

		for (int i = 0; i < m; i++)
			for (int j = sum; j >= nod[i].p; j--)
				dp[j] = max(dp[j], dp[j - nod[i].dis] * (1 - nod[i].p));

		for (int i = sum; i >= 0; i--)
			if (1 - dp[i] < p){  //金钱从大往小遍历一边,只要被抓的概率不超过题目给的概率就输出
				printf("%d\n", i);
				break;
			}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值