poj_3274 Gold Balanced Lineup(数字哈希)

11 篇文章 0 订阅
5 篇文章 0 订阅
Gold Balanced Lineup
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15074 Accepted: 4361

Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of theK possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated integers,  N and  K
Lines 2.. N+1: Line  i+1 contains a single  K-bit integer specifying the features present in cow  i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature # K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range

坑点很多的数字哈希。
题意比较难看懂,其实就是找一段最长的连续区间使得区间中所有数的二进制每位加起来都相等。
可以先求出第一只到第i只奶牛的的二进制每位之和sum(i)(j) (j代表二进制位数),然后发现从第a只奶牛
到第b只奶牛之间刚好是题目要求的黄金区间时,正好满足sum(a)和sum(b)每一位都同时减去 任意一个相同位置所对应的数 
后两者相等。比如sum(a)(a1-a1,a2-a1,a3-a1) == sum(b)(b1-b1,b2-b1,b3-b1)。所以可以用哈希表存储 二进制数字和数组 和 该数
字和对应的奶牛编号,然后再进行操作。有一个坑点是第0只奶牛也要加入哈希表,不然会漏掉最长区间刚好从第一只奶牛开
始的情况。还有是注意求key值时key有可能是负数,要做绝对值运算。然后我自己因为手误把while写成if,居然过了自己给的
所有数据,当然提交后是wa的,多检查了好久,吃个教训,还有要注意数据范围,不要数组越界。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define inf 0x3f3f3f3f
#define maxn 100010
#define mod 100007
#define PI acos(-1.0)
#define LL long long
using namespace std;

struct Node
{
    int val[30];
    int pos;
    int next;
}node[maxn];

int n, k;
int cot;
int hashTable[maxn];
int ans;

int getHash(int *a)
{
    int key = 0;
    for(int i = 0; i < k; i++) key += a[i] * (i+1);
    return abs(key) % mod;
}

void initHash()
{
    cot = 0;
    memset(hashTable, -1, sizeof(hashTable));
}

void insertHash(int *val, int key, int pos)
{
    for(int i = 0; i < k; i++) node[cot].val[i] = val[i];
    node[cot].pos = pos;
    node[cot].next = hashTable[key];
    hashTable[key] = cot++;
}

bool cmp(int *a, int *b)
{
    for(int i = 0; i < k; i++) if(a[i] != b[i]) return false;
    return true;
}

bool searchHash(int *val, int pos)
{
    int key = getHash(val);
    int next = hashTable[key];

    while(next != -1)
    {
        if(cmp(val, node[next].val))
        {
            int t = pos - node[next].pos;
            if(ans < t) ans = t;
            return true;
        }
        next = node[next].next;
    }
    insertHash(val, key, pos);
    return false;
}

int sum[maxn][30];

int main()
{
    while(~scanf("%d%d", &n, &k))
    {
        initHash();
        int old;
        ans = 0;
        int temp[30];
        memset(temp, 0, sizeof(temp));
        insertHash(temp, 0, 0);
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &old);
            for(int now = old, j = 0; j < k; now >>= 1, j++) sum[i][j] = sum[i-1][j] + (now&1);
            for(int j = 0; j < k; j++) temp[j] = sum[i][j] - sum[i][k-1];
            searchHash(temp, i);
        }
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值