POJ Gold Balanced Lineup 3274 哈希

3 篇文章 0 订阅


                          Gold Balanced Lineup
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14640 Accepted: 4249

Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of onlyK different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits featurei.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cowsi..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated integers, N and K.
Lines 2.. N+1: Line i+1 contains a single K-bit integer specifying the features present in cow i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature # K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range

Source



让我们求一个区间,这个区间中每种特征都是相同的

 7          1 1 1                1

   6          0 1 1                2

   7          1 1 1                3

   2          0 1 0                4

   1          1 0 0                5

   4          0 0 1                6

   2          0 1 0                7


按行累加得:

1 1 1

1 2 2

2 3 3

2 4 3

3 4 3

3 4 4

3 5 4

都减去第一列得:

0 0 0

0 1 1

0 1 1

0 2 1

0 1 0

0 1 1

0 2 1

所以说  最大区间是  6-2 = 4.

按行累加,只有这个区间中每个特征相等,区间的两头减去最右列才会相等,所以我们找最远的相等的。

用哈希记录,然后比较

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <vector>
#include <algorithm>
using namespace std;
#define prime 501
vector<int >ha[505];
int c[100001][35],ma=0,tot,sum[100001][35],n,m;
int cmp(int x,int y)//比较
{
    int t=0;
    while(c[x][t]==c[y][t] && t<m)
        t++;
    if(t==m)
        return 1;
    return 0;
}
int main()
{
    int i,j,l;
    long long x;
    scanf("%d%d",&n,&m);
    memset(sum,0,sizeof(sum));
    memset(c,0,sizeof(c));
    for(i=1;i<=n;i++)
    {
        scanf("%lld",&x);
        for(j=0;j<m;j++)//算特征 二进制
        {
            l=x%2;
            x=x/2;//除2
            sum[i][j]=sum[i-1][j]+l;//按行累加
 }
    }
    for(i=1;i<=n;i++)
    {
        int su=0;
        tot=0;
        for(j=0;j<m;j++)
        {
            c[i][j]=sum[i][j]-sum[i][0];//减最右一列
            if(!c[i][j])tot++;
            su=(su+c[i][j])%prime;
        }
        su=abs(su);
        if(tot==m && i>ma)ma=i;//如果全是0的情况,直接找出来
        ha[su].push_back(i);
    }
    for(i=0;i<prime;i++)//比较
    {
        int ll=ha[i].size();
        if(ll>1)
        for(int k=0;k<ll-1;k++)
        {
            for(j=k+1;j<ll;j++)
            {
                if(cmp(ha[i][k],ha[i][j]) && ha[i][j]-ha[i][k]>ma)
                {
                    ma=ha[i][j]-ha[i][k];
                }
            }
        }
    }
    printf("%d\n",ma);
    return 0;
}


















评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值