HDOJ 5325 Crazy Bobo 树形DP


按照升序或者降序选择的点集可以满足条件.....

树上的每个节点可以从子节点转移,也可以从父亲节点转移

Crazy Bobo

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 325    Accepted Submission(s): 100


Problem Description
Bobo has a tree,whose vertices are conveniently labeled by 1,2,...,n.Each node has a weight  wi . All the weights are distrinct.
A set with m nodes  v1,v2,...,vm  is a Bobo Set if:
- The subgraph of his tree induced by this set is connected.
- After we sort these nodes in set by their weights in ascending order,we get  u1,u2,...,um ,(that is, wui<wui+1  for i from 1 to m-1).For any node  x  in the path from  ui  to  ui+1 (excluding  ui  and  ui+1 ),should satisfy  wx<wui .
Your task is to find the maximum size of Bobo Set in a given tree.
 

Input
The input consists of several tests. For each tests:
The first line contains a integer n ( 1n500000 ). Then following a line contains n integers  w1,w2,...,wn  ( 1wi109 ,all the  wi  is distrinct).Each of the following n-1 lines contain 2 integers  ai  and  bi ,denoting an edge between vertices  ai  and  bi  ( 1ai,bin ).
The sum of n is not bigger than 800000.
 

Output
For each test output one line contains a integer,denoting the maximum size of Bobo Set.
 

Sample Input
  
  
7 3 30 350 100 200 300 400 1 2 2 3 3 4 4 5 5 6 6 7
 

Sample Output
  
  
5
 

Source
 

/* ***********************************************
Author        :CKboss
Created Time  :2015年07月28日 星期二 16时28分41秒
File Name     :1010.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

#pragma comment(linker, "/STACK:102400000,102400000")

using namespace std;

const int INF=0x3f3f3f3f;
const int maxn=500500;

int n;
int f[maxn];
int w[maxn];

struct Edge
{
	int to,next;
}edge[maxn*2];

int Adj[maxn],Size;
int dp[maxn];

void init()
{
	memset(Adj,-1,sizeof(Adj)); Size=0;
}

void Add_Edge(int u,int v)
{
	edge[Size].to=v;
	edge[Size].next=Adj[u];
	Adj[u]=Size++;
}

void dfs(int u,int fa)
{
	f[u]=fa;
	dp[u]=1;
	for(int i=Adj[u];~i;i=edge[i].next)
	{
		int v=edge[i].to;
		if(v==fa) continue;
		dfs(v,u);
		if(w[u]<w[v]) dp[u]+=dp[v];
	}
}

int up[maxn];
bool used[maxn];

int dfs_fa(int u)
{
	if(used[u]==true) return up[u];

	used[u]=true;

	int v=f[u];

	if(w[v]>w[u])
	{
		up[u]=dp[v]+dfs_fa(v);
	}

	return up[u];
	
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	while(scanf("%d",&n)!=EOF)
	{
		init();

		memset(dp,0,sizeof(dp));
		memset(up,0,sizeof(up));
		memset(f,0,sizeof(f));
		memset(used,false,sizeof(used)); used[0]=true;

		for(int i=1;i<=n;i++) 
		{
			scanf("%d",w+i); //Add_Edge(0,i);
		}
		w[0]=INF;
		for(int i=0,u,v;i<n-1;i++)
		{
			scanf("%d%d",&u,&v);
			Add_Edge(u,v); Add_Edge(v,u);
		}
		dfs(1,0);
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			ans=max(ans,dp[i]+dfs_fa(i));
		}

		printf("%d\n",ans);
	}
    
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值