POJ 2409 Let it Bead Polya定理


Let it Bead
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4210 Accepted: 2761

Description

"Let it Bead" company is located upstairs at 700 Cannery Row in Monterey, CA. As you can deduce from the company name, their business is beads. Their PR department found out that customers are interested in buying colored bracelets. However, over 90 percent of the target audience insists that the bracelets be unique. (Just imagine what happened if two women showed up at the same party wearing identical bracelets!) It's a good thing that bracelets can have different lengths and need not be made of beads of one color. Help the boss estimating maximum profit by calculating how many different bracelets can be produced. 

A bracelet is a ring-like sequence of s beads each of which can have one of c distinct colors. The ring is closed, i.e. has no beginning or end, and has no direction. Assume an unlimited supply of beads of each color. For different values of s and c, calculate the number of different bracelets that can be made.

Input

Every line of the input file defines a test case and contains two integers: the number of available colors c followed by the length of the bracelets s. Input is terminated by c=s=0. Otherwise, both are positive, and, due to technical difficulties in the bracelet-fabrication-machine, cs<=32, i.e. their product does not exceed 32.

Output

For each test case output on a single line the number of unique bracelets. The figure below shows the 8 different bracelets that can be made with 2 colors and 5 beads.

Sample Input

1 1
2 1
2 2
5 1
2 5
2 6
6 2
0 0

Sample Output

1
2
3
5
8
13
21

Source


一串项链有s个珠子串成,用c种颜色对珠子涂染,问能形成多少种不同的项链。
1.旋转:将项链顺时针旋转i后,其循环节为gcd(s,i),即s与i的最大公约数。
2翻转:(1)当s为奇数时,共有s个循环节数为(s+1)/2的循环群。
(2)当s为偶数时,共有n/2个循环节数为(n+2)/2的循环群,和n/2个循环节数为n/2的循环群。
通过polya奇数定理就能计算出。
Polya定理:设G是n个对象的一个置换群,用m种颜色涂染这n个对象,则不同染色的方案数L=1/|G|*[m^p(a1)+m^p(a2)+....+m^p(an)].其中p(ai)是某个置换的循环数.
//384K	0MS
#include<stdio.h>
#include<math.h>
int gcd(int a,int b)
{
    if(!b)return a;
    return gcd(b,a%b);
}
int main()
{
    int c,s;
    while(scanf("%d%d",&c,&s),c|s)
    {
        int sum=0;
        for(int i=1;i<=s;i++)
        {
            int tmp=gcd(s,i);//第i次旋转的循环节数
            sum+=(int)(pow(c*1.0,tmp*1.0));
        }
        if(s&1)sum+=(int)(s*pow(c*1.0,(s+1)/2.0));//s为奇数,共有s个循环节数均为(s+1)/2的置换
        else//当s为偶数
        {
            sum+=(int)((s/2)*pow(c*1.0,(s+2)/2.0));//第一种循环节数均为(s+2)/2
            sum+=(int)((s/2)*pow(c*1.0,s/2.0));//第二种循环节数均为s/2
        }
        sum/=(2*s);
        printf("%d\n",sum);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值