UVA 10269 Adventure of Super Mario floyd dp

Problem A
Adventure of Super Mario
Input:
 Standard Input
Output: Standard Output

After rescuing the beautiful princess, Super Mario needs to find a way home -- with the princess of course :-) He's very familiar with the 'Super Mario World', so he doesn't need a map, he only needs the best route in order to save time.

There are A Villages and B Castles in the world. Villages are numbered 1..A, and Castles are numbered A+1..A+B. Mario lives in Village 1, and the castle he starts from is numbered A+B. Also, there are two-way roads connecting them. Two places are connected by at most one road and a place never has a road connecting to itself. Mario has already measured the length of every road, but they don't want to walk all the time, since he walks one unit time for one unit distance(how slow!).

Luckily, in the Castle where he saved the princess, Mario found a magic boot. If he wears it, he can super-run from one place to another IN NO TIME. (Don't worry about the princess, Mario has found a way to take her with him when super-running, but he wouldn't tell you :-P)

Since there are traps in the Castles, Mario NEVER super-runs through a Castle. He always stops when there is a castle on the way. Also, he starts/stops super-runnings ONLY at Villages or Castles.

Unfortunately, the magic boot is too old, so he cannot use it to cover more than L kilometers at a time, and he cannot use more than K times in total. When he comes back home, he can have it repaired and make it usable again.

Input

The first line in the input contains a single integer T, indicating the number of test cases. (1<=T<=20) Each test case begins with five integers A, B, M, L and K -- the number of Villages, the number of Castles(1<=A,B<=50), the number of roads, the maximal distance that can be covered at a time(1<=L<=500), and the number of times the boot can be used. (0<=K<=10) The next M lines each contains three integers Xi, Yi, Li. That means there is a road connecting place Xi and Yi. The distance is Li, so the walk time is also Li. (1<=Li<=100)

Output

For each test case in the input print a line containing a single integer indicating the minimal time needed to go home with the beautiful princess. It's guaranteed that Super Mario can always go home.

Sample Input

1
4 2 6 9 1
4 6 1
5 6 10
4 5 5
3 5 4
2 3 4
1 2 3

Sample Output

9
__________________________________________________________________________________________
Rujia Liu

------------------

挖坑

------------------

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstring>
#include <queue>
#include <iostream>
using namespace std;
#define REP(i, n) for (int i=0;i<int(n);++i)
#define REP_1(i, n) for (int i=1;i<=int(n);++i)
#define Display_1(A, n, m) {                    \
    REP_1(i, n){                                \
        REP_1(j, m) cout << A[i][j] << " ";     \
        cout << endl;                           \
    }                                           \
}

const int INF=0x3f3f3f3f;//无穷大
const int maxm=41111;//边的最大数量,为原图的两倍
const int maxn=111;//点的最大数量
const int maxk=20;
int A,B,M,L,K;
int n;
int a[maxn][maxn];
int f[maxn][maxn];
bool v[maxn][maxn];

int main()
{
    int T;
    scanf("%d",&T);
    while (T--){
        scanf("%d%d%d%d%d",&A,&B,&M,&L,&K);
        //init()
        n=A+B;
        memset(a,0x3f,sizeof(a));
        memset(f,0,sizeof(f));
        memset(v,0,sizeof(v));
        for (int i=1;i<=n;i++) a[i][i]=0;
        //input()
        for (int i=1;i<=M;i++){
            int x,y,t;
            scanf("%d%d%d",&x,&y,&t);
            a[x][y]=t;
            a[y][x]=t;
            if (t<=L) v[x][y]=true;
        }
        //floyd
        for (int k=1;k<=n;k++){
            for (int i=1;i<=n;i++){
                for (int j=1;j<=n;j++){
                    if (a[i][k]+a[k][j]<a[i][j]){
                        a[i][j]=a[i][k]+a[k][j];
                        if (k<=A&&a[i][j]<=L) v[i][j]=v[j][i]=true;

                    }
                }
            }
        }
        //Display_1(a,n,n);
        //DP()
        for (int i=1;i<=n;i++) f[i][0]=a[1][i];
        for (int i=0;i<=K;i++) f[1][i]=0;
        for (int i=2;i<=n;i++){
            for (int k=1;k<=K;k++){
                int Min=INF;
                for (int j=1;j<i;j++){
                    if (v[j][i]){
                        Min=min(Min,f[j][k-1]);
                    }
                    Min=min(Min,f[j][k]+a[j][i]);
                }
                f[i][k]=Min;
            }
        }
        printf("%d\n",f[n][K]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值