【PAT (Advanced Level)】1008. Elevator (20)

1008. Elevator (20)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41

这个题目说明很明确,就是电梯上下停,然后计算它的总时间。比较好的是,这道题无关电梯算法,所有的输入是当做每次只有一个人在电梯内,每次只用满足一个人的需求。

代码很直观:

/************************************
This is a test program for anything
Enjoy IT!
************************************/

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <vector>
#include <list>
#include <set>
#include <fstream>
#include <string>
#include <cmath>
using namespace std;

int main()
{
	/*ifstream cin;
	cin.open("in.txt");
	ofstream cout;
	cout.open("out.txt");*/
	//
	// TO DO Whatever You WANT!
	const int UP_TIME = 6;                                                                         // 常量定义
	const int DOWN_TIME = 4;
	const int STAY_TIME = 5;
	int n;
	while (cin >> n)
	{
		int now = 0, total_time = 0;
		for (int i = 0; i < n; i++)                                                            // 依次满足输入
		{
			int go;
			cin >> go;
			if (go > now)                                                                  // 上楼,注意补上停留时间
			{
				total_time += UP_TIME * (go - now) + STAY_TIME;
			}
			else if (go < now)                                                             // 下楼
			{
				total_time += DOWN_TIME * (now - go) + STAY_TIME;
			}
			else                                                                           // 注意可能有不上不下
			{
				total_time += STAY_TIME;
			}
			now = go;                                                                      // 更改当前楼层
		}
		cout << total_time << endl;
	}
	//
	// system("pause");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值