1633: Moo Volume

1633: Moo Volume 分享至QQ空间 去爱问答提问或回答

时间限制(普通/Java):1000MS/10000MS     内存限制:65536KByte
总提交: 437            测试通过:125

描述

Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise. 

FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.

输入

* Line 1: N 

* Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).

输出

There are five cows at locations 1, 5, 3, 2, and 4.

样例输入

   
   
5 1 5 3 2 4

样例输出

   
   
40

提示

INPUT DETAILS: 

There are five cows at locations 1, 5, 3, 2, and 4. 

OUTPUT DETAILS: 

Cow at 1 contributes 1+2+3+4=10, cow at 5 contributes 4+3+2+1=10, cow at 3 contributes 2+1+1+2=6, cow at 2 contributes 1+1+2+3=7, and cow at 4 contributes 3+2+1+1=7. The total volume is (10+10+6+7+7) = 40.

题目来源

USACO January 2005




1->排序

2->套公式,公式来法见下面步奏(不专业,但直白易懂)

3->ans*2输出





距离*几个*次数  

Ai-Ai-1)*(n-i)*i  或者 Ai+1-Ai)*(n-1-i)*(i+1) 具体看自己用法

源码如下:

#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
    __int64 Array[10001],ans,n;
    cin>>n;
    for(int i = 0 ; i < n ; i++)
    {
        cin>>Array[i];
    }
    sort(Array,Array+n);
    ans = 0;
    for(int i = 1 ; i < n ; i++)
    {
        ans+=(Array[i]-Array[i-1])*(n-i)*i;
    }
    cout<<ans*2<<endl;
    return 9;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值