poj——2231——Moo Volume

Description

Farmer John has received a noise complaint from his neighbor, Farmer Bob, stating that his cows are making too much noise. 

FJ's N cows (1 <= N <= 10,000) all graze at various locations on a long one-dimensional pasture. The cows are very chatty animals. Every pair of cows simultaneously carries on a conversation (so every cow is simultaneously MOOing at all of the N-1 other cows). When cow i MOOs at cow j, the volume of this MOO must be equal to the distance between i and j, in order for j to be able to hear the MOO at all. Please help FJ compute the total volume of sound being generated by all N*(N-1) simultaneous MOOing sessions.

Input

* Line 1: N 

* Lines 2..N+1: The location of each cow (in the range 0..1,000,000,000).

Output

There are five cows at locations 1, 5, 3, 2, and 4.

Sample Input

5
1
5
3
2
4

Sample Output

40

注意不要超时

#include <iostream>
#include <cstring>
#include <iomanip>
using namespace std;

int n;
long long  a[10005];
long long sum;
long long dp[10005];

int main()
{
    while (cin>>n)
    {
        for (int i=1;i<=n;i++)
            cin>>a[i];
        sort(a+1,a+n+1);
        dp[1]=0;
        for (int i=2;i<=n;i++)
        {
            dp[i]=dp[i-1]+(a[i]-a[i-1])*(i-1);
            sum+=dp[i];
        }
        dp[n]=0;
        for (int i=n-1;i>=1;i--)
        {
            dp[i]=dp[i+1]+(a[i+1]-a[i])*(n-i);
            sum+=dp[i];
        }
        cout<<sum<<endl;

    }
    return 0;
}



                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值